summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-08-23 12:28:53 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-08-23 12:28:53 -0400
commit2ae5bc3f71bef743193479d34203a7f72d010f6c (patch)
treee01408be6b0937894d2bed0725e30b227df4e722 /app-portage
parentdev-libs/boost: backport math header fix (diff)
downloadgentoo-2ae5bc3f71bef743193479d34203a7f72d010f6c.tar.gz
gentoo-2ae5bc3f71bef743193479d34203a7f72d010f6c.tar.bz2
gentoo-2ae5bc3f71bef743193479d34203a7f72d010f6c.zip
app-portage/iwdevtools: add 0.3.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/iwdevtools/Manifest1
-rw-r--r--app-portage/iwdevtools/iwdevtools-0.3.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-portage/iwdevtools/Manifest b/app-portage/iwdevtools/Manifest
index 7c269a9af5af..c4931cc02acf 100644
--- a/app-portage/iwdevtools/Manifest
+++ b/app-portage/iwdevtools/Manifest
@@ -1,2 +1,3 @@
DIST iwdevtools-0.1.1.tar.gz 16139 BLAKE2B effceb407319d2f8acf44db5642a55c426c73628bef9c2004dd76118dc042cbc1178975e06b14d6950cef417790693af9a98dc77e4873f0175a408ca14f71384 SHA512 b0d3a1145c3ecfc71e7f8b0d8d8e321840869037841e1faa547ad4a385751b4fb13de31b3ed497eeacbdf227a81c4f28ff6fd229b008105489ada7c1a15b88e4
DIST iwdevtools-0.2.0.tar.gz 23498 BLAKE2B 50c946bb69ae720b27836aebb825d6b1e9545e80dda6d0c939c4be7be30f0f4017c309b2794805fc030e074cc2629bbc328545024d5f89860d05693731ab0b55 SHA512 c31d8646477f1cb8ab784441e2f16155248fc337d2138ce6780810dc7e81cdd6792d610db26e8f7759f89f50732c784bf4938c4a861420412f0056fd9b391a08
+DIST iwdevtools-0.3.0.tar.gz 25463 BLAKE2B 0a5a3e151209e206b077d4c70e19b545641251e43715d9ada7d8b379525afd8b12223d7c76db4e909e63b86f916ea525dbc2f470ac83978ef3f1310c7c6ddb12 SHA512 1d956e0e9e8e6ad9db3d19ec2bc5e312303f3ba300ef4e593ab0743adaaa094e78df125d779a8a6f663f7fe531d1f1d58fae2ef72736a99edd412be167746301
diff --git a/app-portage/iwdevtools/iwdevtools-0.3.0.ebuild b/app-portage/iwdevtools/iwdevtools-0.3.0.ebuild
new file mode 100644
index 000000000000..7637b8439253
--- /dev/null
+++ b/app-portage/iwdevtools/iwdevtools-0.3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson optfeature
+
+DESCRIPTION="Small tools to aid with Gentoo development, primarily intended for QA"
+HOMEPAGE="https://github.com/ionenwks/iwdevtools"
+SRC_URI="https://github.com/ionenwks/iwdevtools/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-misc/pax-utils
+ app-portage/portage-utils
+ sys-apps/diffutils
+ sys-apps/file
+ sys-apps/portage
+ sys-apps/util-linux"
+
+src_configure() {
+ meson_src_configure -Ddocdir=${PF}
+}
+
+pkg_postinst() {
+ optfeature "detecting potential ABI issues using abidiff" dev-util/libabigail
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "To (optionally) integrate with portage, inspect the .bashrc files installed"
+ elog "at ${EROOT}/usr/share/${PN}. If not already using a bashrc, you can use"
+ elog "the example bashrc directly by creating a symlink:"
+ elog
+ elog " ln -s ../../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
+ elog
+ elog "See ${EROOT}/usr/share/doc/${PF}/README.rst* for info on tools."
+ fi
+}