summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-04 21:06:37 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-04 21:12:43 +0100
commit361ee9df2fcac49714d358ad83b6e6c5c4291f92 (patch)
treeaf261bf073f51295644aca30c328caa8dfa8a49b /app-portage
parentmedia-video/mpv: kill py27 (diff)
downloadgentoo-361ee9df2fcac49714d358ad83b6e6c5c4291f92.tar.gz
gentoo-361ee9df2fcac49714d358ad83b6e6c5c4291f92.tar.bz2
gentoo-361ee9df2fcac49714d358ad83b6e6c5c4291f92.zip
app-portage/flaggie: EAPI 7, newer impls
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/flaggie/flaggie-0.2.1-r1.ebuild19
-rw-r--r--app-portage/flaggie/flaggie-9999.ebuild8
2 files changed, 15 insertions, 12 deletions
diff --git a/app-portage/flaggie/flaggie-0.2.1-r1.ebuild b/app-portage/flaggie/flaggie-0.2.1-r1.ebuild
index d16a34cf3a3f..2257dbe98c4e 100644
--- a/app-portage/flaggie/flaggie-0.2.1-r1.ebuild
+++ b/app-portage/flaggie/flaggie-0.2.1-r1.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-PYTHON_COMPAT=( python{2_7,3_5,3_6} pypy )
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} )
inherit bash-completion-r1 distutils-r1
@@ -24,13 +25,13 @@ python_install_all() {
}
pkg_postinst() {
- ewarn "Please denote that flaggie creates backups of your package.* files"
+ ewarn "Please note that flaggie creates backups of your package.* files"
ewarn "before performing each change through appending a single '~'."
ewarn "If you'd like to keep your own backup of them, please use another"
ewarn "naming scheme (or even better some VCS)."
- elog
- elog "bash-completion support requires:"
- elog " app-shells/gentoo-bashcomp"
- has_version app-shells/gentoo-bashcomp && \
- elog "(installed already)"
+ if ! has_version app-shells/gentoo-bashcomp; then
+ elog
+ elog "If you want to use bash-completion, you need to install:"
+ elog " app-shells/gentoo-bashcomp"
+ fi
}
diff --git a/app-portage/flaggie/flaggie-9999.ebuild b/app-portage/flaggie/flaggie-9999.ebuild
index d979063b48d1..4a0285406c39 100644
--- a/app-portage/flaggie/flaggie-9999.ebuild
+++ b/app-portage/flaggie/flaggie-9999.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} )
EGIT_REPO_URI="https://github.com/mgorny/flaggie.git"
inherit bash-completion-r1 distutils-r1 git-r3