summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-02-22 19:55:25 -0500
committerAnthony G. Basile <blueness@gentoo.org>2016-02-22 19:55:42 -0500
commit3faadaff44e4a25f13c271c323c51365f3109bee (patch)
tree091c2e31272056734857976e25c7ba2ef8ceb7f3 /app-portage
parentMerge github#845: app-benchmarks/bonnie++: fixes a couple of bugs and bump to... (diff)
downloadgentoo-3faadaff44e4a25f13c271c323c51365f3109bee.tar.gz
gentoo-3faadaff44e4a25f13c271c323c51365f3109bee.tar.bz2
gentoo-3faadaff44e4a25f13c271c323c51365f3109bee.zip
app-portage/grs: check kernel config for CGROUPS
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/grs/grs-9999.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/app-portage/grs/grs-9999.ebuild b/app-portage/grs/grs-9999.ebuild
index 7eb8426470ad..9f02750daee1 100644
--- a/app-portage/grs/grs-9999.ebuild
+++ b/app-portage/grs/grs-9999.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
+inherit linux-info
+
PYTHON_COMPAT=( python3_4 )
inherit distutils-r1
@@ -38,6 +40,12 @@ RDEPEND="
sys-kernel/genkernel-next
)"
+pkg_setup() {
+ linux-info_pkg_setup
+ CONFIG_CHECK="~CGROUPS"
+ ERROR_CGROUPS="WARNING: grsrun requires CONFIG_CGROUPS enabled in the kernel."
+}
+
src_install() {
distutils-r1_src_install
echo "CONFIG_PROTECT=\"/etc/grs/systems.conf\"" > "${T}"/20grs