summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2016-05-06 22:51:28 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-05-06 22:51:44 +0200
commit5fde9b5cebf8bcbe36f6901b740dd80db2ddb30b (patch)
tree79bdb7c867bd65ba83ee1da1798cde124f0ae184 /app-portage
parentvirtual/perl-Memoize: Copy keywords from provider =dev-lang/perl-5.20.2 (diff)
downloadgentoo-5fde9b5cebf8bcbe36f6901b740dd80db2ddb30b.tar.gz
gentoo-5fde9b5cebf8bcbe36f6901b740dd80db2ddb30b.tar.bz2
gentoo-5fde9b5cebf8bcbe36f6901b740dd80db2ddb30b.zip
app-portage/g-cpan: Various updates to live ebuild and version bump
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/g-cpan/Manifest1
-rw-r--r--app-portage/g-cpan/g-cpan-0.16.7.ebuild55
-rw-r--r--app-portage/g-cpan/g-cpan-9999.ebuild27
3 files changed, 74 insertions, 9 deletions
diff --git a/app-portage/g-cpan/Manifest b/app-portage/g-cpan/Manifest
index a2f909a97665..d19ca60ca37e 100644
--- a/app-portage/g-cpan/Manifest
+++ b/app-portage/g-cpan/Manifest
@@ -1,2 +1,3 @@
DIST g-cpan-0.16.5.tar.gz 33894 SHA256 929c06ee2cdd3361121b6f359ea7fc9201bc42caff96ef1df45b4cb93ccfd988 SHA512 f2eab23281abe567ee2df42895e3f0783228c6ab5e3a8230089e900fd2700367d736299da20fb228f2d4542491a24da05fd035a81aff7d79ce5132e35c48ad0b WHIRLPOOL 01e0b9fc59264455d57fc64c432e683ae941c74d6efa6e2b3430dea6caac019cfad3e893a4b39de4386a3dadadecf95d828a9fbaa8e8b1260303081e2cc6ce65
DIST g-cpan-0.16.6.tar.gz 33844 SHA256 efd0a99483d8ce4a6c828f145592846e6076887b33f95431d7b8256c6973906d SHA512 f8e9e211ffc09ca42d1444a42ad2b8111beb8988e4a01387cf8788f7e4a52e6133168820c2800ac82429fa022e2ff473a774c48ac140b5cde184b3d77cd6e1b1 WHIRLPOOL 95d7db1905df41f320b8876a02f53e3238d55ab1be30e4b086ed362797819629997edd06e167c21325cc8d13540247a842cedcfcf1a236737fec91835b952252
+DIST g-cpan-0.16.7.tar.gz 33621 SHA256 35ead4120bee1b4158413eb1f5933baf1ce75500495d590163fbfef95c9c171f SHA512 2412b30fa4c3432882db0f31da6ace841e353a363e15a3b536ea1febcf601a7f9c4e14968e3abcf848e3557098088012472179688caf36cd97ae9b528a3db7fb WHIRLPOOL 646f76745023ae815ebecf57856b50dcd568657df68aee89099dd64904a4d43e9cef82f4f16518bd0b8db50e3ddd57aa200bf8fcffbd6539305f59be798bece1
diff --git a/app-portage/g-cpan/g-cpan-0.16.7.ebuild b/app-portage/g-cpan/g-cpan-0.16.7.ebuild
new file mode 100644
index 000000000000..a547d863bb0e
--- /dev/null
+++ b/app-portage/g-cpan/g-cpan-0.16.7.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit perl-module
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/gentoo-perl/g-cpan.git"
+ inherit git-r3
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/gentoo-perl/g-cpan/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="Autogenerate and install ebuilds for CPAN modules"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Perl/g-cpan"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+IUSE="test"
+
+COMMONDEPEND="
+ virtual/perl-File-Path
+ virtual/perl-File-Spec
+ dev-perl/Log-Agent
+ virtual/perl-Memoize
+ virtual/perl-IO
+ dev-perl/Shell-EnvImporter
+ virtual/perl-Term-ANSIColor
+ >=dev-perl/YAML-0.60
+"
+RDEPEND="${COMMONDEPEND}
+ >=sys-apps/portage-2.0.0
+"
+DEPEND="${COMMONDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( >=virtual/perl-Test-Simple-0.940.0 )
+"
+
+src_install() {
+ perl-module_src_install
+ diropts -m0775 -o portage -g portage
+ dodir "/var/tmp/g-cpan"
+ dodir "/var/log/g-cpan"
+ keepdir "/var/log/g-cpan"
+}
+
+pkg_postinst() {
+ elog "If you want to use g-cpan as non root user you may wish to adjust"
+ elog "the permissions on /var/tmp/g-cpan or add users to the portage group."
+ elog "Please note that some CPAN packages need additional manual"
+ elog "parameters or tweaking, due to bugs in their build systems."
+}
diff --git a/app-portage/g-cpan/g-cpan-9999.ebuild b/app-portage/g-cpan/g-cpan-9999.ebuild
index 1ff7291fd259..a547d863bb0e 100644
--- a/app-portage/g-cpan/g-cpan-9999.ebuild
+++ b/app-portage/g-cpan/g-cpan-9999.ebuild
@@ -10,25 +10,34 @@ if [[ ${PV} == "9999" ]] ; then
inherit git-r3
SRC_URI=""
else
- SRC_URI="https://dev.gentoo.org/~dilfridge/distfiles/${P}.tar.gz"
+ SRC_URI="https://github.com/gentoo-perl/g-cpan/releases/download/v${PV}/${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
fi
-DESCRIPTION="g-cpan: generate and install CPAN modules using portage"
+DESCRIPTION="Autogenerate and install ebuilds for CPAN modules"
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Perl/g-cpan"
LICENSE="|| ( Artistic GPL-2 )"
SLOT="0"
-IUSE=""
+IUSE="test"
-DEPEND="
- >=dev-perl/YAML-0.60
- >=dev-perl/Shell-EnvImporter-1.70.0-r2
+COMMONDEPEND="
+ virtual/perl-File-Path
+ virtual/perl-File-Spec
dev-perl/Log-Agent
+ virtual/perl-Memoize
+ virtual/perl-IO
+ dev-perl/Shell-EnvImporter
+ virtual/perl-Term-ANSIColor
+ >=dev-perl/YAML-0.60
"
-RDEPEND="${DEPEND}
+RDEPEND="${COMMONDEPEND}
>=sys-apps/portage-2.0.0
"
+DEPEND="${COMMONDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( >=virtual/perl-Test-Simple-0.940.0 )
+"
src_install() {
perl-module_src_install
@@ -39,8 +48,8 @@ src_install() {
}
pkg_postinst() {
- elog "If you want to use g-cpan besides root you may wish to"
- elog " adjust the permissions on /var/tmp/g-cpan or add users into portage group."
+ elog "If you want to use g-cpan as non root user you may wish to adjust"
+ elog "the permissions on /var/tmp/g-cpan or add users to the portage group."
elog "Please note that some CPAN packages need additional manual"
elog "parameters or tweaking, due to bugs in their build systems."
}