summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-07 22:09:09 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-08 00:15:26 +0100
commit7166bcf1dfc943fc8c43402aea49c97e8246545c (patch)
treefe093426c0075bf7ec72346bf41399cb3a55c47c /app-portage
parentapp-portage/gpyutils: Limit to py3.8+ due to pkgcore (diff)
downloadgentoo-7166bcf1dfc943fc8c43402aea49c97e8246545c.tar.gz
gentoo-7166bcf1dfc943fc8c43402aea49c97e8246545c.tar.bz2
gentoo-7166bcf1dfc943fc8c43402aea49c97e8246545c.zip
app-portage/smart-live-rebuild: Limit to py3.8+ due to pkgcore
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/smart-live-rebuild/smart-live-rebuild-1.3.6-r1.ebuild36
-rw-r--r--app-portage/smart-live-rebuild/smart-live-rebuild-9999.ebuild6
2 files changed, 39 insertions, 3 deletions
diff --git a/app-portage/smart-live-rebuild/smart-live-rebuild-1.3.6-r1.ebuild b/app-portage/smart-live-rebuild/smart-live-rebuild-1.3.6-r1.ebuild
new file mode 100644
index 000000000000..ccc36895bd2e
--- /dev/null
+++ b/app-portage/smart-live-rebuild/smart-live-rebuild-1.3.6-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Check live packages for updates and emerge them as necessary"
+HOMEPAGE="https://github.com/mgorny/smart-live-rebuild/"
+SRC_URI="https://github.com/mgorny/smart-live-rebuild/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+IUSE=""
+
+RDEPEND=">=app-portage/gentoopm-0.2.1[${PYTHON_USEDEP}]"
+
+# Tests need to be fixed
+RESTRICT=test
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /etc/portage
+ newins smart-live-rebuild.conf{.example,}
+ insinto /usr/share/portage/config/sets
+ newins sets.conf.example smart-live-rebuild.conf
+}
diff --git a/app-portage/smart-live-rebuild/smart-live-rebuild-9999.ebuild b/app-portage/smart-live-rebuild/smart-live-rebuild-9999.ebuild
index 1f974965eedd..adf1f7f98aec 100644
--- a/app-portage/smart-live-rebuild/smart-live-rebuild-9999.ebuild
+++ b/app-portage/smart-live-rebuild/smart-live-rebuild-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_COMPAT=( python3_{8..9} )
EGIT_REPO_URI="https://github.com/mgorny/${PN}.git"
inherit distutils-r1 git-r3