summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-20 21:22:01 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-20 21:34:22 +0100
commit7c29851a31c132a6a8ad7939134db13dce1ed813 (patch)
tree4f8854173bfab2ccfdbec05fc72647321c2ff641 /app-portage
parentsys-fs/duperemove: Remove old (diff)
downloadgentoo-7c29851a31c132a6a8ad7939134db13dce1ed813.tar.gz
gentoo-7c29851a31c132a6a8ad7939134db13dce1ed813.tar.bz2
gentoo-7c29851a31c132a6a8ad7939134db13dce1ed813.zip
app-portage/eix: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/eix/Manifest2
-rw-r--r--app-portage/eix/eix-0.34.10.ebuild102
-rw-r--r--app-portage/eix/eix-0.34.9.ebuild102
3 files changed, 0 insertions, 206 deletions
diff --git a/app-portage/eix/Manifest b/app-portage/eix/Manifest
index e1815e619a5c..eed43fefef11 100644
--- a/app-portage/eix/Manifest
+++ b/app-portage/eix/Manifest
@@ -1,3 +1 @@
-DIST eix-0.34.10.tar.xz 630356 BLAKE2B 6336652dbb3703295693dea40cb2d2a2d5c7fc17d28150faae07b566cccfddb8d103b83c5db34e839434b1fbbe0ff87a08c4af84d2f80c5e9b786d88d5743f96 SHA512 35270b7fafe6a13ebb33271b3baba07f61928d9c9c40aafabc47d8f7bd4a8d44e1013004361e9cf81e8517d5b1a8a3010d18c6fcac02dcc8b44dc443762f82a3
DIST eix-0.34.11.tar.xz 629932 BLAKE2B 7b203a4763a880379e5bafe086f70aeca6ad508cd558cc53d53683d8ee4a85111ba9fdea9fa81cd9c3939dd01ea392876b2714257138fd40a2c6b124e0fdbc90 SHA512 518dee499ed27acd39ea4c26e7b94a1098408b1d8cf6bc593e5e4b06aa973ae664e155886681c1e90e4a89afe8b54e05f8bd08d6ace2a2e1559fa613e5a351e7
-DIST eix-0.34.9.tar.xz 629672 BLAKE2B ba9a5de98f74baa711e7483e284980c0fe5e956512de590954bf848f6cf6baad5db899256e927e7cb984d7276157fa9c42052cc8fb1ccc52e5e530cc31d39d84 SHA512 5cb00c813bc31971a0cfd77cae0c676040d33f24963cb241274918d2e381956ca949593e0637d81040a9751db0a925552913188cc25ada9a90c6007c31f72e43
diff --git a/app-portage/eix/eix-0.34.10.ebuild b/app-portage/eix/eix-0.34.10.ebuild
deleted file mode 100644
index f11bcd6edbb7..000000000000
--- a/app-portage/eix/eix-0.34.10.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools bash-completion-r1 flag-o-matic tmpfiles
-
-DESCRIPTION="Search and query ebuilds"
-HOMEPAGE="https://github.com/vaeth/eix/"
-SRC_URI="https://github.com/vaeth/eix/releases/download/v${PV}/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug doc nls sqlite"
-
-BOTHDEPEND="nls? ( virtual/libintl )
- sqlite? ( >=dev-db/sqlite-3:= )"
-RDEPEND="${BOTHDEPEND}
- >=app-shells/push-2.0-r1
- >=app-shells/quoter-3.0_p2-r1"
-DEPEND="${BOTHDEPEND}
- app-arch/xz-utils
- nls? ( sys-devel/gettext )"
-
-pkg_setup() {
- # remove stale cache file to prevent collisions
- local old_cache=${EROOT}/var/cache/${PN}
- if [[ -f ${old_cache} ]]; then
- rm "${old_cache}" || die
- fi
-}
-
-src_prepare() {
- default
- sed -i -e "s:/:${EPREFIX}/:" tmpfiles.d/eix.conf || die
-
- sed -e "/eixf_source=/s:push.sh:cat \"${EPREFIX}/usr/share/push/push.sh\":" \
- -e "/eixf_source=/s:quoter_pipe.sh:cat \"${EPREFIX}/usr/share/quoter/quoter_pipe.sh\":" \
- -i src/eix-functions.sh.in || die
- sed -e "s:'\$(bindir)/eix-functions.sh':cat \\\\\"${EPREFIX}/usr/share/eix/eix-functions\\\\\":" \
- -i src/Makefile.am || die
-
- eautoreconf
-}
-
-src_configure() {
- local myconf=(
- $(use_enable debug paranoic-asserts)
- $(use_enable nls)
- $(use_with doc extra-doc)
- $(use_with sqlite)
- --without-protobuf
-
- # default configuration
- $(use_with prefix always-accept-keywords)
- --with-dep-default
- --with-required-use-default
-
- # paths
- --with-portage-rootpath="${ROOTPATH}"
- --with-eprefix-default="${EPREFIX}"
-
- # build a single executable with symlinks
- --disable-separate-binaries
- --disable-separate-tools
-
- # used purely to control/disrespect *FLAGS
- --disable-debugging
- --disable-new_dialect
- --disable-optimization
- --disable-strong-optimization
- --disable-security
- --disable-nopie-security
- --disable-strong-security
- )
-
- econf "${myconf[@]}"
-}
-
-src_install() {
- default
- dobashcomp bash/eix
- dotmpfiles tmpfiles.d/eix.conf
-
- rm -r "${ED}"/usr/bin/eix-functions.sh || die
-}
-
-pkg_postinst() {
- tmpfiles_process eix.conf
-
- local obs=${EROOT}/var/cache/eix.previous
- if [[ -f ${obs} ]]; then
- ewarn "Found obsolete ${obs}, please remove it"
- fi
-}
-
-pkg_postrm() {
- if [[ ! -n ${REPLACED_BY_VERSION} ]]; then
- rm -rf "${EROOT}/var/cache/${PN}" || die
- fi
-}
diff --git a/app-portage/eix/eix-0.34.9.ebuild b/app-portage/eix/eix-0.34.9.ebuild
deleted file mode 100644
index 27581250b045..000000000000
--- a/app-portage/eix/eix-0.34.9.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools bash-completion-r1 flag-o-matic tmpfiles
-
-DESCRIPTION="Search and query ebuilds"
-HOMEPAGE="https://github.com/vaeth/eix/"
-SRC_URI="https://github.com/vaeth/eix/releases/download/v${PV}/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug doc nls sqlite"
-
-BOTHDEPEND="nls? ( virtual/libintl )
- sqlite? ( >=dev-db/sqlite-3:= )"
-RDEPEND="${BOTHDEPEND}
- >=app-shells/push-2.0-r1
- >=app-shells/quoter-3.0_p2-r1"
-DEPEND="${BOTHDEPEND}
- app-arch/xz-utils
- nls? ( sys-devel/gettext )"
-
-pkg_setup() {
- # remove stale cache file to prevent collisions
- local old_cache=${EROOT}/var/cache/${PN}
- if [[ -f ${old_cache} ]]; then
- rm "${old_cache}" || die
- fi
-}
-
-src_prepare() {
- default
- sed -i -e "s:/:${EPREFIX}/:" tmpfiles.d/eix.conf || die
-
- sed -e "/eixf_source=/s:push.sh:cat \"${EPREFIX}/usr/share/push/push.sh\":" \
- -e "/eixf_source=/s:quoter_pipe.sh:cat \"${EPREFIX}/usr/share/quoter/quoter_pipe.sh\":" \
- -i src/eix-functions.sh.in || die
- sed -e "s:'\$(bindir)/eix-functions.sh':cat \\\\\"${EPREFIX}/usr/share/eix/eix-functions\\\\\":" \
- -i src/Makefile.am || die
-
- eautoreconf
-}
-
-src_configure() {
- local myconf=(
- $(use_enable debug paranoic-asserts)
- $(use_enable nls)
- $(use_with doc extra-doc)
- $(use_with sqlite)
- --without-protobuf
-
- # default configuration
- $(use_with prefix always-accept-keywords)
- --with-dep-default
- --with-required-use-default
-
- # paths
- --with-portage-rootpath="${ROOTPATH}"
- --with-eprefix-default="${EPREFIX}"
-
- # build a single executable with symlinks
- --disable-separate-binaries
- --disable-separate-tools
-
- # used purely to control/disrespect *FLAGS
- --disable-debugging
- --disable-new_dialect
- --disable-optimization
- --disable-strong-optimization
- --disable-security
- --disable-nopie-security
- --disable-strong-security
- )
-
- econf "${myconf[@]}"
-}
-
-src_install() {
- default
- dobashcomp bash/eix
- dotmpfiles tmpfiles.d/eix.conf
-
- rm -r "${ED}"/usr/bin/eix-functions.sh || die
-}
-
-pkg_postinst() {
- tmpfiles_process eix.conf
-
- local obs=${EROOT}/var/cache/eix.previous
- if [[ -f ${obs} ]]; then
- ewarn "Found obsolete ${obs}, please remove it"
- fi
-}
-
-pkg_postrm() {
- if [[ ! -n ${REPLACED_BY_VERSION} ]]; then
- rm -rf "${EROOT}/var/cache/${PN}" || die
- fi
-}