summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-22 13:08:22 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-22 13:27:28 +0100
commit9770c1023c0623c4240b816da208e3f5afe0c696 (patch)
treee9d78bf2376c87ac6073998eaf78b88dfa920002 /app-portage
parentdev-python/pycairo: Stabilize 1.25.1 amd64, #917717 (diff)
downloadgentoo-9770c1023c0623c4240b816da208e3f5afe0c696.tar.gz
gentoo-9770c1023c0623c4240b816da208e3f5afe0c696.tar.bz2
gentoo-9770c1023c0623c4240b816da208e3f5afe0c696.zip
app-portage/nattka: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/nattka/nattka-0.4.1-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-portage/nattka/nattka-0.4.1-r1.ebuild b/app-portage/nattka/nattka-0.4.1-r1.ebuild
new file mode 100644
index 000000000000..297f33a55447
--- /dev/null
+++ b/app-portage/nattka/nattka-0.4.1-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A New Arch Tester Toolkit -- open-source stable-bot replacement"
+HOMEPAGE="
+ https://github.com/projg2/nattka/
+ https://pypi.org/project/nattka/
+"
+SRC_URI="
+ https://github.com/projg2/nattka/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="depgraph-order"
+
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-util/pkgcheck[${PYTHON_USEDEP}]
+ dev-vcs/git
+ sys-apps/pkgcore[${PYTHON_USEDEP}]
+ depgraph-order? (
+ dev-python/networkx[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ >=dev-python/flit-core-3.7.1[${PYTHON_USEDEP}]
+ test? (
+ dev-python/vcrpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests pytest