summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2020-12-05 16:18:07 +0100
committerFabian Groffen <grobian@gentoo.org>2020-12-05 16:18:18 +0100
commitbb38524702384def9d248bfdc092b44537b1eef8 (patch)
tree69041eb0083066831dc352f8fca8eb710ef8e324 /app-portage
parentsys-devel/libtool-2.4.6: add macOS Big Sur patch (diff)
downloadgentoo-bb38524702384def9d248bfdc092b44537b1eef8.tar.gz
gentoo-bb38524702384def9d248bfdc092b44537b1eef8.tar.bz2
gentoo-bb38524702384def9d248bfdc092b44537b1eef8.zip
app-portage/elt-patches-20201205: version bump for macOS Big Sur fix
Closes: https://bugs.gentoo.org/758473 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/elt-patches/Manifest1
-rw-r--r--app-portage/elt-patches/elt-patches-20201205.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/app-portage/elt-patches/Manifest b/app-portage/elt-patches/Manifest
index a0bca80effe2..070ebbf0a35c 100644
--- a/app-portage/elt-patches/Manifest
+++ b/app-portage/elt-patches/Manifest
@@ -2,3 +2,4 @@ DIST elt-patches-20170317.tar.xz 23356 BLAKE2B 8e402496e4c064a56a6bafbf369bf9771
DIST elt-patches-20170422.tar.xz 27864 BLAKE2B 0b6a764a7030d78618139f2c2a51f33b224f38e9f117ce45d119375e20566df55266f9684b53d3d311f91570803f937922f93801ad5a3664dae70828ebbedd12 SHA512 90867925f797ec815cfd8f45655cbc0bdc5f46e1a84792988ca76aaed97489907a926acf8f50c0499c56f6e70ea7081732f71c74a8d49bf24a6d265a0a4202dc
DIST elt-patches-20170815.tar.xz 27864 BLAKE2B ca699e3fc3f5903f660fba70aa424603d42ef3b3aaa5e8768cfad0561d423972b21e75e578faeaaa89d8b0932f5161079a57e5d0d4ab7b56d5a09b91fb0e8d46 SHA512 deba10767b6a8cb5e8139e6f47a30e6f8a4a9312adb1d3e0199df24321d89601915fc91003da2d14fda679e7cbd30a4d4cf39d94ba57bce06432eefc168650dd
DIST elt-patches-20170826.1.tar.xz 27912 BLAKE2B 886644713651448784e040fbcde6ef11f98f12abffb347f2213b990c1f0ec2df3af6c729c18781235a393e6de907b4da6ec5d140f7fb856466de6e7cefd54b00 SHA512 30a1e8b77d2963b7c56eef3a7a0a576ea6d30f1133c7bf6ad3b5b57cbe3e2de5e8cfbc50a929fea589b42ca02802a7ed16ccf7adb868290a2cc3add5b4fc77d3
+DIST elt-patches-20201205.tar.xz 39240 BLAKE2B aa2e2377f0d0cba14f38c59664174d066eff04c9d2a71346c998c4324987fbce25cfd91b79e8e40bde0d81bf7d3c43126bffd0a6b0b219aaad11f4f9f22abde4 SHA512 67e199f060e2c93e01b7a7809f52c0a18d82e86f1b1eb34b965c2acd24e5538a874b820028e363d3002cf58b43c2fe3376ae28d2bef0ca81feabb90c83ae47c2
diff --git a/app-portage/elt-patches/elt-patches-20201205.ebuild b/app-portage/elt-patches/elt-patches-20201205.ebuild
new file mode 100644
index 000000000000..e6ebc44e78a3
--- /dev/null
+++ b/app-portage/elt-patches/elt-patches-20201205.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Collection of patches for libtool.eclass"
+HOMEPAGE="https://gitweb.gentoo.org/proj/elt-patches.git/"
+SRC_URI="https://dev.gentoo.org/~grobian/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~x86-cygwin ~amd64-linux ~arm64-linux ~ppc64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE=""
+
+RDEPEND="sys-apps/gentoo-functions"
+DEPEND="app-arch/xz-utils"
+
+src_compile() {
+ emake rootprefix="${EPREFIX}" libdirname="$(get_libdir)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" rootprefix="${EPREFIX}" install
+}