summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2020-01-03 14:18:58 -0800
committerZac Medico <zmedico@gentoo.org>2020-01-03 14:22:11 -0800
commitbcbf06297bfbfd46bc75f430472265016f890153 (patch)
treee7b33d0509ffdd2ea995f1936ca2e81476c3b520 /app-portage
parentdev-python/pytest-runner: Drop 2.11.1, 2.6.2, 4.0 (diff)
downloadgentoo-bcbf06297bfbfd46bc75f430472265016f890153.tar.gz
gentoo-bcbf06297bfbfd46bc75f430472265016f890153.tar.bz2
gentoo-bcbf06297bfbfd46bc75f430472265016f890153.zip
app-portage/repoman: Remove old versions
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/repoman/repoman-2.3.17.ebuild63
-rw-r--r--app-portage/repoman/repoman-2.3.18.ebuild63
-rw-r--r--app-portage/repoman/repoman-2.3.19.ebuild63
3 files changed, 0 insertions, 189 deletions
diff --git a/app-portage/repoman/repoman-2.3.17.ebuild b/app-portage/repoman/repoman-2.3.17.ebuild
deleted file mode 100644
index f4313d582c61..000000000000
--- a/app-portage/repoman/repoman-2.3.17.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
-PYTHON_REQ_USE='bzip2(+)'
-
-inherit distutils-r1
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/portage.git"
- S="${WORKDIR}/${P}/repoman"
-else
- SRC_URI="https://dev.gentoo.org/~zmedico/portage/archives/${P}.tar.bz2"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
-
-DESCRIPTION="Repoman is a Quality Assurance tool for Gentoo ebuilds"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- >=sys-apps/portage-2.3.43[${PYTHON_USEDEP}]
- >=dev-python/lxml-3.6.0[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-
-python_test() {
- esetup.py test
-}
-
-python_install() {
- # Install sbin scripts to bindir for python-exec linking
- # they will be relocated in pkg_preinst()
- distutils-r1_python_install \
- --system-prefix="${EPREFIX}/usr" \
- --bindir="$(python_get_scriptdir)" \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- --htmldir="${EPREFIX}/usr/share/doc/${PF}/html" \
- --sbindir="$(python_get_scriptdir)" \
- --sysconfdir="${EPREFIX}/etc" \
- "${@}"
-}
-
-pkg_postinst() {
- if [[ -z {REPLACING_VERSIONS} ]]; then
- elog ""
- elog "This release of repoman is from the new portage/repoman split"
- elog "release code base."
- elog "This new repoman code base is still being developed. So its API's"
- elog "are not to be considered stable and are subject to change."
- elog "The code released has been tested and considered ready for use."
- elog "This however does not guarantee it to be completely bug free."
- elog "Please report any bugs you may encounter."
- elog ""
- fi
-}
diff --git a/app-portage/repoman/repoman-2.3.18.ebuild b/app-portage/repoman/repoman-2.3.18.ebuild
deleted file mode 100644
index 7ce444e76570..000000000000
--- a/app-portage/repoman/repoman-2.3.18.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
-PYTHON_REQ_USE='bzip2(+)'
-
-inherit distutils-r1
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/portage.git"
- S="${WORKDIR}/${P}/repoman"
-else
- SRC_URI="https://dev.gentoo.org/~zmedico/portage/archives/${P}.tar.bz2"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
-
-DESCRIPTION="Repoman is a Quality Assurance tool for Gentoo ebuilds"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- >=sys-apps/portage-2.3.72[${PYTHON_USEDEP}]
- >=dev-python/lxml-3.6.0[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-
-python_test() {
- esetup.py test
-}
-
-python_install() {
- # Install sbin scripts to bindir for python-exec linking
- # they will be relocated in pkg_preinst()
- distutils-r1_python_install \
- --system-prefix="${EPREFIX}/usr" \
- --bindir="$(python_get_scriptdir)" \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- --htmldir="${EPREFIX}/usr/share/doc/${PF}/html" \
- --sbindir="$(python_get_scriptdir)" \
- --sysconfdir="${EPREFIX}/etc" \
- "${@}"
-}
-
-pkg_postinst() {
- if [[ -z {REPLACING_VERSIONS} ]]; then
- elog ""
- elog "This release of repoman is from the new portage/repoman split"
- elog "release code base."
- elog "This new repoman code base is still being developed. So its API's"
- elog "are not to be considered stable and are subject to change."
- elog "The code released has been tested and considered ready for use."
- elog "This however does not guarantee it to be completely bug free."
- elog "Please report any bugs you may encounter."
- elog ""
- fi
-}
diff --git a/app-portage/repoman/repoman-2.3.19.ebuild b/app-portage/repoman/repoman-2.3.19.ebuild
deleted file mode 100644
index 55dce4a172b2..000000000000
--- a/app-portage/repoman/repoman-2.3.19.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} )
-PYTHON_REQ_USE='bzip2(+)'
-
-inherit distutils-r1
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/portage.git"
- S="${WORKDIR}/${P}/repoman"
-else
- SRC_URI="https://dev.gentoo.org/~zmedico/portage/archives/${P}.tar.bz2"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
-
-DESCRIPTION="Repoman is a Quality Assurance tool for Gentoo ebuilds"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- >=sys-apps/portage-2.3.80[${PYTHON_USEDEP}]
- >=dev-python/lxml-3.6.0[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-
-python_test() {
- esetup.py test
-}
-
-python_install() {
- # Install sbin scripts to bindir for python-exec linking
- # they will be relocated in pkg_preinst()
- distutils-r1_python_install \
- --system-prefix="${EPREFIX}/usr" \
- --bindir="$(python_get_scriptdir)" \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- --htmldir="${EPREFIX}/usr/share/doc/${PF}/html" \
- --sbindir="$(python_get_scriptdir)" \
- --sysconfdir="${EPREFIX}/etc" \
- "${@}"
-}
-
-pkg_postinst() {
- if [[ -z {REPLACING_VERSIONS} ]]; then
- elog ""
- elog "This release of repoman is from the new portage/repoman split"
- elog "release code base."
- elog "This new repoman code base is still being developed. So its API's"
- elog "are not to be considered stable and are subject to change."
- elog "The code released has been tested and considered ready for use."
- elog "This however does not guarantee it to be completely bug free."
- elog "Please report any bugs you may encounter."
- elog ""
- fi
-}