summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-21 15:24:46 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-21 15:24:55 +0100
commitc14fee852bfbf9a4681123e09a9048ee89accb8d (patch)
treed339309869e2c3cbe9132a827ac15522929e48ee /app-portage
parentdev-python/sympy: Remove unneeded useflag descriptions from metadata.xml (diff)
downloadgentoo-c14fee852bfbf9a4681123e09a9048ee89accb8d.tar.gz
gentoo-c14fee852bfbf9a4681123e09a9048ee89accb8d.tar.bz2
gentoo-c14fee852bfbf9a4681123e09a9048ee89accb8d.zip
app-portage/eclass-manpages: Use portageq to detect overlay locations
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/eclass-manpages/eclass-manpages-20150814-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-portage/eclass-manpages/eclass-manpages-20150814-r1.ebuild b/app-portage/eclass-manpages/eclass-manpages-20150814-r1.ebuild
new file mode 100644
index 000000000000..eafea7c90de1
--- /dev/null
+++ b/app-portage/eclass-manpages/eclass-manpages-20150814-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="collection of Gentoo eclass manpages"
+HOMEPAGE="https://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE=""
+
+S=${WORKDIR}
+
+genit() {
+ local e=${1:-${ECLASSDIR}}
+ einfo "Generating man pages from: ${e}"
+ # Need `bash` because the .sh isn't +x on the servers #451352
+ env ECLASSDIR=${e} bash "${FILESDIR}"/eclass-to-manpage.sh || die
+}
+
+src_compile() {
+ # First process any eclasses found in overlays. Then process
+ # the main eclassdir last so that its output will clobber anything
+ # that might have come from overlays. Main tree wins!
+ local o e
+ for o in $(portageq get_repos /) ; do
+ e="$(portageq get_repo_path / ${o})/eclass"
+ [[ -d ${e} ]] || continue
+ genit "${e}" || die
+ done
+ genit || die
+}
+
+src_install() {
+ doman *.5
+}