summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-04-13 15:31:07 +0200
committerMichał Górny <mgorny@gentoo.org>2018-04-13 15:31:14 +0200
commitff513d3274d3d103d701025bcc8255d49b157456 (patch)
tree4428f272d99b93e6745eb67bdba373288c0b1d4e /app-portage
parentmedia-gfx/shotwell: Version bump to shotwell-0.28.2 (diff)
downloadgentoo-ff513d3274d3d103d701025bcc8255d49b157456.tar.gz
gentoo-ff513d3274d3d103d701025bcc8255d49b157456.tar.bz2
gentoo-ff513d3274d3d103d701025bcc8255d49b157456.zip
app-portage/gemato: Bump to 13.0 (non-parallel version)
Bug: https://bugs.gentoo.org/647964
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gemato/Manifest1
-rw-r--r--app-portage/gemato/gemato-13.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-portage/gemato/Manifest b/app-portage/gemato/Manifest
index ed3cb4b697f7..b764cdeecb4a 100644
--- a/app-portage/gemato/Manifest
+++ b/app-portage/gemato/Manifest
@@ -1,2 +1,3 @@
DIST gemato-12.1.tar.gz 66807 BLAKE2B 7a6155f337d382bdea7fb4f0bbcb0982e8d4237502dfa7fd8006754bc15e2bfe1f58f133f8cc24ee39eaf947e0770f9ff0672769daa0f03d790ef88958877417 SHA512 7d6287b335121d38859e43ce0818ebb86c51105ed836594f0540fda5ff683a6e58ce09b7dad9cea0667e6379cca6902225b095a3d0922a12cd8c62a36b11386c
DIST gemato-12.2.tar.gz 66897 BLAKE2B 85ca439620afdb2045e571ed7a11f3eb8ce85e41c0984ad51af3b9d22c0926138eda0c7b02e1d70e200eb8c93cf4003e61f901e0fd5fd28861217b02a1e3ab64 SHA512 10ba7da5de3b90722b0bdcf9d3766a7c83c68d29d23e49744a31b0c8ad80eaa4917dff2fbd9f12ef2fa4fde03244e79f6fe5e9c108db7fb64fd6ea68fa0eb81c
+DIST gemato-13.0.tar.gz 66899 BLAKE2B e75a16d6a26f010801df072154897a485e9aee6434cf60962d59d11fda70b790284a734d9137ccc7910b0a95278d922640aece45e42ca497d1118e01992c2a15 SHA512 0ca17f1df8606e09a88411d75d144094bd13e440b04721175c8d9a3ea92fc616b34de0c80c817898ee94a1d82e37e4de50319634a351a52bccaec9653ad2f166
diff --git a/app-portage/gemato/gemato-13.0.ebuild b/app-portage/gemato/gemato-13.0.ebuild
new file mode 100644
index 000000000000..41600021c7a3
--- /dev/null
+++ b/app-portage/gemato/gemato-13.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# pyblake2 & pysha3 are broken with pypy3
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+PYTHON_REQ_USE='threads(+)'
+inherit distutils-r1
+
+DESCRIPTION="Stand-alone Manifest generation & verification tool"
+HOMEPAGE="https://github.com/mgorny/gemato"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x64-cygwin ~amd64-fbsd"
+IUSE="+blake2 bzip2 +gpg lzma sha3 test"
+
+MODULE_RDEPEND="
+ blake2? ( $(python_gen_cond_dep 'dev-python/pyblake2[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )
+ bzip2? ( $(python_gen_cond_dep 'dev-python/bz2file[${PYTHON_USEDEP}]' python2_7 pypy) )
+ gpg? ( app-crypt/gnupg )
+ lzma? ( $(python_gen_cond_dep 'dev-python/backports-lzma[${PYTHON_USEDEP}]' python2_7 pypy) )
+ sha3? ( $(python_gen_cond_dep 'dev-python/pysha3[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )"
+
+RDEPEND="${MODULE_RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${MODULE_RDEPEND} )"
+
+python_test() {
+ esetup.py test
+}