summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-01-26 02:50:12 -0500
committerMike Frysinger <vapier@gentoo.org>2016-01-26 02:52:19 -0500
commit9a80064e5bdb270313ad4a531e413b62d7374a60 (patch)
tree4576ed728427412345085d761c712ada0be834c3 /app-shells/bash/bash-4.2_p53.ebuild
parentmedia-libs/imlib2: set KEYWORDS in ebuild for stabilization #572884 (diff)
downloadgentoo-9a80064e5bdb270313ad4a531e413b62d7374a60.tar.gz
gentoo-9a80064e5bdb270313ad4a531e413b62d7374a60.tar.bz2
gentoo-9a80064e5bdb270313ad4a531e413b62d7374a60.zip
app-shells/bash: enable USE=static support in SLOT-ed ebuilds
Diffstat (limited to 'app-shells/bash/bash-4.2_p53.ebuild')
-rw-r--r--app-shells/bash/bash-4.2_p53.ebuild21
1 files changed, 10 insertions, 11 deletions
diff --git a/app-shells/bash/bash-4.2_p53.ebuild b/app-shells/bash/bash-4.2_p53.ebuild
index 1705530d6509..98d2e555595c 100644
--- a/app-shells/bash/bash-4.2_p53.ebuild
+++ b/app-shells/bash/bash-4.2_p53.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -35,14 +35,16 @@ SRC_URI="mirror://gnu/bash/${MY_P}.tar.gz $(patches)"
LICENSE="GPL-3"
SLOT="${MY_PV}"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
-IUSE="afs mem-scramble +net nls +readline"
+IUSE="afs mem-scramble +net nls +readline static"
-DEPEND=">=sys-libs/ncurses-5.2-r2
- readline? ( >=sys-libs/readline-6.2 )
- nls? ( virtual/libintl )"
-RDEPEND="${DEPEND}"
+LIB_DEPEND=">=sys-libs/ncurses-5.2-r2[static-libs(+)]
+ nls? ( virtual/libintl )
+ readline? ( >=sys-libs/readline-6.2[static-libs(+)] )"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
# we only need yacc when the .y files get patched (bash42-005)
-DEPEND+=" virtual/yacc"
+DEPEND="${RDEPEND}
+ virtual/yacc
+ static? ( ${LIB_DEPEND} )"
S=${WORKDIR}/${MY_P}
@@ -93,10 +95,7 @@ src_configure() {
-DNON_INTERACTIVE_LOGIN_SHELLS \
-DSSH_SOURCE_BASHRC
- # Don't even think about building this statically without
- # reading Bug 7714 first. If you still build it statically,
- # don't come crying to us with bugs ;).
- #use static && export LDFLAGS="${LDFLAGS} -static"
+ use static && append-ldflags -static
use nls || myconf+=( --disable-nls )
# Historically, we always used the builtin readline, but since