summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-12-07 03:15:58 -0500
committerMike Frysinger <vapier@gentoo.org>2016-12-07 03:15:58 -0500
commit8e5c3e67e5230051c3b6690ef8da675466e2f540 (patch)
tree980d0c424bb708532cec2539440a2d42814242f9 /app-shells/bashdb/bashdb-4.3.0.91-r2.ebuild
parentsys-apps/memtest86+: fix missing ssp flags on test/random objects #590974 (diff)
downloadgentoo-8e5c3e67e5230051c3b6690ef8da675466e2f540.tar.gz
gentoo-8e5c3e67e5230051c3b6690ef8da675466e2f540.tar.bz2
gentoo-8e5c3e67e5230051c3b6690ef8da675466e2f540.zip
app-shells/bashdb: hardcode path to debugger main #591994
This isn't a great solution, but considering bash hasn't changed its path in decades, it shouldn't be a big deal. It's better than relying on the output of `strings` on the /bin/bash binary.
Diffstat (limited to 'app-shells/bashdb/bashdb-4.3.0.91-r2.ebuild')
-rw-r--r--app-shells/bashdb/bashdb-4.3.0.91-r2.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/app-shells/bashdb/bashdb-4.3.0.91-r2.ebuild b/app-shells/bashdb/bashdb-4.3.0.91-r2.ebuild
index 63d4d411d957..4179d15f91d4 100644
--- a/app-shells/bashdb/bashdb-4.3.0.91-r2.ebuild
+++ b/app-shells/bashdb/bashdb-4.3.0.91-r2.ebuild
@@ -27,3 +27,9 @@ src_prepare() {
# We don't install this, so don't bother building it. #468044
sed -i 's:texi2html:true:' doc/Makefile.in || die
}
+
+src_configure() {
+ # This path matches the bash sources. If we ever change bash,
+ # we'll probably have to change this to match. #591994
+ econf --with-dbg-main='$(PKGDATADIR)/bashdb-main.inc'
+}