summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-05-20 02:07:07 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-05-20 02:19:17 +0200
commit41be65b0a1909090de5df0bf30247d52a9dbb4b4 (patch)
treeead7f0863a40b1f4b4eacaaff440aeb4d6e0a6c1 /app-shells/dash
parentdev-util/byacc: Bump to v20180510 (diff)
downloadgentoo-41be65b0a1909090de5df0bf30247d52a9dbb4b4.tar.gz
gentoo-41be65b0a1909090de5df0bf30247d52a9dbb4b4.tar.bz2
gentoo-41be65b0a1909090de5df0bf30247d52a9dbb4b4.zip
app-shells/dash: Bump to v0.5.10.2
Package-Manager: Portage-2.3.38, Repoman-2.3.9
Diffstat (limited to 'app-shells/dash')
-rw-r--r--app-shells/dash/Manifest1
-rw-r--r--app-shells/dash/dash-0.5.10.2.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/app-shells/dash/Manifest b/app-shells/dash/Manifest
index 28e096423d1c..0ee0aee331ef 100644
--- a/app-shells/dash/Manifest
+++ b/app-shells/dash/Manifest
@@ -1,2 +1,3 @@
DIST dash-0.5.10.1.tar.gz 225253 BLAKE2B 55dbdca7f01d19656e002d6e210bcae920619e2e88d4d174a3e08cbbc40bf867ece3f24ce9690ec64f95b1f0995ab35cabc08381ac031a33b55282cec0b09e73 SHA512 7ca3bbcf8bac84d359cde710a9ab393f05cf8522e969a2c110d2e71620e53f349387128045e68738dc621afe0b48f43ae3d32851187f2ae02d49b3e2575ffa6b
+DIST dash-0.5.10.2.tar.gz 225196 BLAKE2B af48879d29aee8041949b51f08eb89c3938e77b2e05553a3e1a9939da7b00fd80f7b9fb35f33e18b0c11850bfb1b8377e9dc9bcfd80754fd29c9d160e0ce5a4d SHA512 0ae29be77794df0ba254967649b9728611a75fbb3acd32ab6634d76399d1ce97c7d12d31da465482a7e4f3207093415c496c39525cace9b78ab3cb9444dd7640
DIST dash-0.5.9.1.tar.gz 225217 BLAKE2B a80aa00ea5418d00b03c9ded21ef5c3a28d599059d1ac2f20082867b71ece6afac2f0bce9bc09946450c7618ad2c7f95df63b3d519a7f56552a291d09e44a71b SHA512 d56a043b8fab4693d3f70cceb531c37174e7ded4acd5549e53048d7ce29125ff21d7e758f51a4a73e06250d051e246467039989275838c19a2579edea3f72b7d
diff --git a/app-shells/dash/dash-0.5.10.2.ebuild b/app-shells/dash/dash-0.5.10.2.ebuild
new file mode 100644
index 000000000000..d51383e2eb19
--- /dev/null
+++ b/app-shells/dash/dash-0.5.10.2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs versionator
+
+#MY_PV="$(get_version_component_range 1-3)"
+DEB_PATCH="" #$(get_version_component_range 4)
+#MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Debian Almquist Shell"
+HOMEPAGE="http://gondor.apana.org.au/~herbert/dash/"
+SRC_URI="http://gondor.apana.org.au/~herbert/dash/files/${P}.tar.gz"
+if [[ -n "${DEB_PATCH}" ]] ; then
+ DEB_PF="${PN}_${MY_PV}-${DEB_PATCH}"
+ SRC_URI+=" mirror://debian/pool/main/d/dash/${DEB_PF}.diff.gz"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="libedit static vanilla"
+
+RDEPEND="!static? ( libedit? ( dev-libs/libedit ) )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ libedit? ( static? ( dev-libs/libedit[static-libs] ) )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.5.9.1-format-security.patch
+)
+
+src_prepare() {
+ if [[ -n "${DEB_PATCH}" ]] ; then
+ eapply "${WORKDIR}"/${DEB_PF}.diff
+ eapply */debian/diff/*
+ fi
+
+ #337329 #527848
+ use vanilla || eapply "${FILESDIR}"/${PN}-0.5.10-dumb-echo.patch
+
+ default
+
+ # Fix the invalid sort
+ sed -i -e 's/LC_COLLATE=C/LC_ALL=C/g' src/mkbuiltins
+
+ # Use pkg-config for libedit linkage
+ sed -i \
+ -e "/LIBS/s:-ledit:\`$(tc-getPKG_CONFIG) --libs libedit $(usex static --static '')\`:" \
+ configure || die
+}
+
+src_configure() {
+ # don't redefine stat on Solaris
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ export ac_cv_func_stat64=yes
+ fi
+ append-cppflags -DJOBS=$(usex libedit 1 0)
+ use static && append-ldflags -static
+ # Do not pass --enable-glob due to #443552.
+ # Autotools use $LINENO as a proxy for extended debug support
+ # (i.e. they're running bash), so disable that. #527644
+ local myeconfargs=(
+ --bindir="${EPREFIX}"/bin
+ --enable-fnmatch
+ --disable-lineno
+ $(use_with libedit)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ if [[ -n "${DEB_PATCH}" ]] ; then
+ dodoc */debian/changelog
+ fi
+}