summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2018-06-30 22:21:12 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2018-06-30 22:21:48 -0700
commitc38398c7c3f3ad9aaa82b14f3c2bc9fc6055da15 (patch)
tree33923db1a7e4041e03f28e118e39681d0484f322 /app-shells/fzy/fzy-0.10_pre20180618.ebuild
parentapp-shells/fzy: add live ebuild (diff)
downloadgentoo-c38398c7c3f3ad9aaa82b14f3c2bc9fc6055da15.tar.gz
gentoo-c38398c7c3f3ad9aaa82b14f3c2bc9fc6055da15.tar.bz2
gentoo-c38398c7c3f3ad9aaa82b14f3c2bc9fc6055da15.zip
app-shells/fzy: add snapshot with working utf-8
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'app-shells/fzy/fzy-0.10_pre20180618.ebuild')
-rw-r--r--app-shells/fzy/fzy-0.10_pre20180618.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-shells/fzy/fzy-0.10_pre20180618.ebuild b/app-shells/fzy/fzy-0.10_pre20180618.ebuild
new file mode 100644
index 000000000000..1e4cb47604e9
--- /dev/null
+++ b/app-shells/fzy/fzy-0.10_pre20180618.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit savedconfig toolchain-funcs
+
+EGIT_COMMIT="2697c02618d908e5bdcae93ab4815b04c49bd25e"
+
+DESCRIPTION="Fuzzy text selector (interactive grep) for console"
+HOMEPAGE="https://github.com/jhawthorn/fzy"
+SRC_URI="https://github.com/jhawthorn/fzy/archive/${EGIT_COMMIT}.tar.gz -> ${PN}-${EGIT_COMMIT}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+PATCHES=(
+ "${FILESDIR}"/fzy-0.9-cflags.patch
+ "${FILESDIR}"/fzy-add-utf-8-support.patch
+)
+
+S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+
+src_prepare() {
+ default
+ restore_config config.h
+ tc-export CC
+}
+
+src_install() {
+ local DOCS=( ALGORITHM.md CHANGELOG.md README.md )
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+ exeinto /usr/share/fzy
+ doexe contrib/fzy-tmux
+ doexe contrib/fzy-dvtm
+ einstalldocs
+ save_config config.h
+}