summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2018-03-02 14:27:26 -0600
committerWilliam Hubbs <williamh@gentoo.org>2018-03-02 14:27:49 -0600
commitfe86446eb3949042c11bb947ebaf5edf23d21e70 (patch)
treeab9aba02da32b4d0aee6c6ef7666970f516ecf92 /app-shells/gentoo-bashcomp
parentx11-wm/windowmaker: stable 0.95.8-r1 for sparc, bug #641172 (diff)
downloadgentoo-fe86446eb3949042c11bb947ebaf5edf23d21e70.tar.gz
gentoo-fe86446eb3949042c11bb947ebaf5edf23d21e70.tar.bz2
gentoo-fe86446eb3949042c11bb947ebaf5edf23d21e70.zip
app-shells/gentoo-bashcomp: 20180302 bump
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-shells/gentoo-bashcomp')
-rw-r--r--app-shells/gentoo-bashcomp/Manifest1
-rw-r--r--app-shells/gentoo-bashcomp/gentoo-bashcomp-20180302.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/app-shells/gentoo-bashcomp/Manifest b/app-shells/gentoo-bashcomp/Manifest
index 433f114d7e60..bfb3d887f35e 100644
--- a/app-shells/gentoo-bashcomp/Manifest
+++ b/app-shells/gentoo-bashcomp/Manifest
@@ -1,3 +1,4 @@
DIST gentoo-bashcomp-20101217.tar.bz2 23095 BLAKE2B a98757ad29d1356976f4196153f0b4a7763c96a9c4f8aae63fc563b52a9944d86c5098efa5ea1a7c4954cf331ae11fb7b1d8e74ad82998a49652eeb195d1af65 SHA512 29c4802b8f71585b7146e454f44700954de8655aa46dda7046338ed46e1e9835f4ea4141cfd5a813a5f75b6586b030e0e0cbde4c8030ec303f98110fa7a5e316
DIST gentoo-bashcomp-20121024.tar.bz2 28025 BLAKE2B 470f844707d31e2eb6af8ad34695960406e494eb81018675460e15def43c26979d73e3fa300283da1c40fee96039bcdac59ca3ce1f826db8362fca7929cb986e SHA512 ca755de801b8ecba6267395930024cbd6eb7f3f78c08de5caff6621bcf99554b68f8d3bb93f517f6a7fe27b08c42c8896910b0b93f8917db6e0172bfd614bacd
DIST gentoo-bashcomp-20140911.tar.bz2 30258 BLAKE2B c41814a51b74b169dc0e92e4af0630a152145f9d8fd81afb29c5c6e28d9c80caf3a57450a02a7f653762a0c91c8e1639f101e7749761b68e75482dad8e303467 SHA512 cacd1c3353bce7e67d00758a714829860111932ab7addd0a84a06cae9218ff18aff4ea562e0682ca4db859408ca15817edd81548d54144223ed5016667549f7f
+DIST gentoo-bashcomp-20180302.tar.bz2 21485 BLAKE2B 887ac5cfa8c6ba431a6aa5f5918b8bdfbe6a1ae9a2e7ac21b3c06ec2062b448d924f928b1372e81749ece6d4aa673bbbaaa364ca744124c842e3819349917169 SHA512 6b4551b078505e6348cb10ca2d67faab4d323a0f0ddefc872145314303d6f95fe31f9706d43d9f20c0139610ce47e4cf70ba7516d911dc4927cfbf5d863bc063
diff --git a/app-shells/gentoo-bashcomp/gentoo-bashcomp-20180302.ebuild b/app-shells/gentoo-bashcomp/gentoo-bashcomp-20180302.ebuild
new file mode 100644
index 000000000000..c67590fe9873
--- /dev/null
+++ b/app-shells/gentoo-bashcomp/gentoo-bashcomp-20180302.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1
+
+DESCRIPTION="Gentoo-specific bash command-line completions (emerge, ebuild, equery, etc)"
+HOMEPAGE="https://www.gentoo.org/"
+SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris"
+IUSE=""
+
+src_install() {
+ emake DESTDIR="${D}" install \
+ completionsdir="$(get_bashcompdir)" \
+ helpersdir="$(get_bashhelpersdir)" \
+ compatdir="${EPREFIX}/etc/bash_completion.d"
+}