summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2020-02-19 14:09:04 -0700
committerChristoph Junghans <junghans@gentoo.org>2020-02-19 14:09:59 -0700
commit2273e31dabc5ca216d1ca8e7c68406b0ad3e5ab6 (patch)
treeba9823367b437d582074c2152511d2edb664d5a3 /app-shells/mpibash
parentmedia-sound/sonata: 1.7_beta1_p20200212 version bump (diff)
downloadgentoo-2273e31dabc5ca216d1ca8e7c68406b0ad3e5ab6.tar.gz
gentoo-2273e31dabc5ca216d1ca8e7c68406b0ad3e5ab6.tar.bz2
gentoo-2273e31dabc5ca216d1ca8e7c68406b0ad3e5ab6.zip
app-shells/mpibash: fix build with mpi-3
Closes: https://bugs.gentoo.org/656422 Closes: https://bugs.gentoo.org/708994 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Christoph Junghans <junghans@gentoo.org>
Diffstat (limited to 'app-shells/mpibash')
-rw-r--r--app-shells/mpibash/Manifest1
-rw-r--r--app-shells/mpibash/files/mpi-3.patch24
-rw-r--r--app-shells/mpibash/mpibash-1.2.ebuild42
-rw-r--r--app-shells/mpibash/mpibash-1.3-r1.ebuild (renamed from app-shells/mpibash/mpibash-1.3.ebuild)8
-rw-r--r--app-shells/mpibash/mpibash-9999.ebuild6
5 files changed, 32 insertions, 49 deletions
diff --git a/app-shells/mpibash/Manifest b/app-shells/mpibash/Manifest
index 38d74257f4f0..b1d1faba4926 100644
--- a/app-shells/mpibash/Manifest
+++ b/app-shells/mpibash/Manifest
@@ -1,2 +1 @@
-DIST mpibash-1.2.tar.gz 347083 BLAKE2B 75b79d8e1f418de8220ff502245bc094774984f4760d922297a2ad2fcdb7d87a4a5d28015fd2686fbc68939ac532551046f8a987166accaa8b96025cce9fc79e SHA512 db755dd2c6212a8d7dfd6cbff17d5dffcbc3b6a0286abdad4d2e21790453d2356e88c566abe4648da138d6964098fad581b8fd5beae1335f5787de92f4659104
DIST mpibash-1.3.tar.gz 369803 BLAKE2B b1959deaa2d5b3bce1a66e5ef0ff41ad156093aec9cc1efcd12873b6d5814ad1586ff951d6fd7f37dab6a55040378774b435edc4e2c8892952480539864f91fa SHA512 4728565239aae80013322231a928fd1e9a59484614a92cf7e314d0cd5c090d3a47de395507ce52f71a6900245855089d659c6509f8c4df3bfd88e46fc2187749
diff --git a/app-shells/mpibash/files/mpi-3.patch b/app-shells/mpibash/files/mpi-3.patch
new file mode 100644
index 000000000000..7b7e1ec820de
--- /dev/null
+++ b/app-shells/mpibash/files/mpi-3.patch
@@ -0,0 +1,24 @@
+From 0b396b62ac314ae509ac3ca5fa9d5119e862be51 Mon Sep 17 00:00:00 2001
+From: Scott Pakin <pakin@lanl.gov>
+Date: Wed, 19 Feb 2020 13:43:40 -0700
+Subject: [PATCH] Replace deprecated MPI_Errhandler_set with newer
+ MPI_Comm_set_errhandler
+
+Resolves #17.
+---
+ src/init.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/init.c b/src/init.c
+index cd070a7..46b1127 100644
+--- a/src/init.c
++++ b/src/init.c
+@@ -77,7 +77,7 @@ mpi_init_builtin (WORD_LIST *list)
+
+ /* Make MPI errors return instead of crash. Also, store our rank
+ * and number of ranks. */
+- MPI_Errhandler_set (MPI_COMM_WORLD, MPI_ERRORS_RETURN);
++ MPI_Comm_set_errhandler (MPI_COMM_WORLD, MPI_ERRORS_RETURN);
+ MPI_Comm_rank (MPI_COMM_WORLD, &mpibash_rank);
+ MPI_Comm_size (MPI_COMM_WORLD, &mpibash_num_ranks);
+
diff --git a/app-shells/mpibash/mpibash-1.2.ebuild b/app-shells/mpibash/mpibash-1.2.ebuild
deleted file mode 100644
index 594ac6bc88cb..000000000000
--- a/app-shells/mpibash/mpibash-1.2.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools-utils multilib
-
-if [[ ${PV} = 9999 ]]; then
- EGIT_REPO_URI="https://github.com/lanl/MPI-Bash.git"
- inherit git-r3
- KEYWORDS=""
- AUTOTOOLS_AUTORECONF=1
-else
- SRC_URI="https://github.com/lanl/MPI-Bash/releases/download/v${PV}/${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-DESCRIPTION="Parallel scripting right from the Bourne-Again Shell (Bash)"
-HOMEPAGE="https://github.com/lanl/MPI-Bash"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="examples"
-
-DEPEND="virtual/mpi
- >=app-shells/bash-4.2[plugins]
- sys-cluster/libcircle"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- local myeconfargs=(
- --with-bashdir="${EPREFIX}"/usr/include/bash-plugins
- --with-plugindir="${EPREFIX}"/usr/$(get_libdir)/bash
- )
- autotools-utils_src_configure
-}
-
-src_install() {
- autotools-utils_src_install
- sed -i '/^export LD_LIBRARY_PATH/d' "${ED}/usr/bin/${PN}" || die
- use examples || rm -r "${ED}/usr/share/doc/${PF}/examples" || die
-}
diff --git a/app-shells/mpibash/mpibash-1.3.ebuild b/app-shells/mpibash/mpibash-1.3-r1.ebuild
index 76bbce43cda2..fcb33db81ee9 100644
--- a/app-shells/mpibash/mpibash-1.3.ebuild
+++ b/app-shells/mpibash/mpibash-1.3-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit autotools multilib
@@ -22,10 +22,12 @@ SLOT="0"
IUSE="examples"
DEPEND="virtual/mpi
- >=app-shells/bash-4.2[plugins]
+ >=app-shells/bash-4.2:0[plugins]
sys-cluster/libcircle"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/mpi-3.patch" )
+
src_prepare() {
default
[[ ${PV} != 9999 ]] || eautoreconf
diff --git a/app-shells/mpibash/mpibash-9999.ebuild b/app-shells/mpibash/mpibash-9999.ebuild
index 76bbce43cda2..5832bd90df0a 100644
--- a/app-shells/mpibash/mpibash-9999.ebuild
+++ b/app-shells/mpibash/mpibash-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit autotools multilib
@@ -22,7 +22,7 @@ SLOT="0"
IUSE="examples"
DEPEND="virtual/mpi
- >=app-shells/bash-4.2[plugins]
+ >=app-shells/bash-4.2:0[plugins]
sys-cluster/libcircle"
RDEPEND="${DEPEND}"