summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2018-06-05 20:53:13 +0300
committerMichał Górny <mgorny@gentoo.org>2018-06-07 20:54:30 +0200
commitdf0e9300c0179adc9f5e03ac9f80fb443281b81e (patch)
treef41ad8bf6a3f58bf5fb4ccb65e096620166f70ff /app-shells/mpv-bash-completion
parentnet-dns/dnscrypt-proxy: bump to 2.0.15, tor aware (diff)
downloadgentoo-df0e9300c0179adc9f5e03ac9f80fb443281b81e.tar.gz
gentoo-df0e9300c0179adc9f5e03ac9f80fb443281b81e.tar.bz2
gentoo-df0e9300c0179adc9f5e03ac9f80fb443281b81e.zip
app-shells/mpv-bash-completion: verbump to 3.3.17
Package-Manager: Portage-2.3.40, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/8731
Diffstat (limited to 'app-shells/mpv-bash-completion')
-rw-r--r--app-shells/mpv-bash-completion/Manifest1
-rw-r--r--app-shells/mpv-bash-completion/mpv-bash-completion-3.3.17.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-shells/mpv-bash-completion/Manifest b/app-shells/mpv-bash-completion/Manifest
index 2f1e2f9d4c67..e274df5a909f 100644
--- a/app-shells/mpv-bash-completion/Manifest
+++ b/app-shells/mpv-bash-completion/Manifest
@@ -1 +1,2 @@
DIST mpv-bash-completion-3.3.16.tar.gz 20125 BLAKE2B 1350445ea05474e553ade334c1f11e97828df11143021920a25787a295d6e870595e35dda6ccd048ed4e01e0e85443a5902893fed1aa1525e875649a93ef632d SHA512 d962cc911d571b0345ddee22ecae6faef307f2da44642d6db5223fb0e51d2b2087b038e1964cf8f1ed683bb95a3268a8ffc1fff2759561100b23921406a0e31f
+DIST mpv-bash-completion-3.3.17.tar.gz 20873 BLAKE2B 5e44b315a4f148c27768a3b0c29d609b679e3d489dd79803795a75a9289816ed13797cc04c748410ba3302a2619dedad21772f2d914b2c3ff5c73189e4e348df SHA512 a0b1ae4b07bd3e5fc95fea135aa5391d0efb0d2c1e4ccbb712cf0911b9e07b23a7bfb27d43b615988610f545f1bc62226998295573480ab657e3b18966d48991
diff --git a/app-shells/mpv-bash-completion/mpv-bash-completion-3.3.17.ebuild b/app-shells/mpv-bash-completion/mpv-bash-completion-3.3.17.ebuild
new file mode 100644
index 000000000000..2aca0b8cc661
--- /dev/null
+++ b/app-shells/mpv-bash-completion/mpv-bash-completion-3.3.17.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1
+
+DESCRIPTION="Bash completion for the mpv video player"
+HOMEPAGE="https://2ion.github.io/mpv-bash-completion/"
+SRC_URI="https://github.com/2ion/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="luajit"
+
+COMMON_DEPEND=">=media-video/mpv-0.25.0[cli]"
+RDEPEND="${COMMON_DEPEND}
+ >=app-shells/bash-completion-2.3-r1
+"
+DEPEND="${COMMON_DEPEND}
+ !luajit? ( dev-lang/lua:* )
+ luajit? ( dev-lang/luajit:2 )
+"
+
+src_prepare() {
+ default_src_prepare
+ # Avoid 'mpv' make target that supports lua only.
+ sed -i -e 's|check: mpv|check:|' Makefile || die
+}
+
+src_compile() {
+ # Prevent access violations from completion generation.
+ # See Gentoo bug 656086.
+ addpredict /dev/dri
+
+ $(usex luajit 'luajit' 'lua') gen.lua > mpv || die
+}
+
+src_install() {
+ dobashcomp mpv
+ einstalldocs
+}
+
+pkg_postinst() {
+ if ! has_version 'x11-apps/xrandr'; then
+ elog
+ elog "If you want completion of window sizes, please install 'x11-apps/xrandr'."
+ elog
+ fi
+}