summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-shells/scsh-install-lib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-shells/scsh-install-lib')
-rw-r--r--app-shells/scsh-install-lib/Manifest1
-rw-r--r--app-shells/scsh-install-lib/metadata.xml8
-rw-r--r--app-shells/scsh-install-lib/scsh-install-lib-1.3.0.ebuild24
3 files changed, 33 insertions, 0 deletions
diff --git a/app-shells/scsh-install-lib/Manifest b/app-shells/scsh-install-lib/Manifest
new file mode 100644
index 000000000000..ad2ca31c1753
--- /dev/null
+++ b/app-shells/scsh-install-lib/Manifest
@@ -0,0 +1 @@
+DIST scsh-install-lib-1.3.0.tar.gz 142852 SHA256 7e536cf11ac309b0ddab797a53211d5dcea55cf47835cfb15626577411ec14ef SHA512 ec9069e7ceb6fe316c8b0d1baf1903f2ce1fa2f3f79dc1bf8356b8064c0596e92c8bbc889c7d27b6456a2a0c49dde984536a05987baccc05f4724992cf90ca98 WHIRLPOOL 391952c84839e304c0cad8b0b109a75223029b1301206696615e5c0a9ed34151bacce4c264f41f76b7ff84a6c75555a4daaaa0a6efcde08f317aaaf8a7869d29
diff --git a/app-shells/scsh-install-lib/metadata.xml b/app-shells/scsh-install-lib/metadata.xml
new file mode 100644
index 000000000000..41e25959213c
--- /dev/null
+++ b/app-shells/scsh-install-lib/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>scheme</herd>
+<use>
+ <flag name='scsh'>Use a non-FHS directory layout</flag>
+</use>
+</pkgmetadata>
diff --git a/app-shells/scsh-install-lib/scsh-install-lib-1.3.0.ebuild b/app-shells/scsh-install-lib/scsh-install-lib-1.3.0.ebuild
new file mode 100644
index 000000000000..d2a96a89a164
--- /dev/null
+++ b/app-shells/scsh-install-lib/scsh-install-lib-1.3.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit scsh
+
+DESCRIPTION="Installation tool for the Scheme Untergrund Library"
+HOMEPAGE="http://lamp.epfl.ch/~schinz/scsh_packages/"
+SRC_URI="http://lamp.epfl.ch/~schinz/scsh_packages/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=app-shells/scsh-0.6.6"
+
+src_install() {
+ dodir $SCSH_MODULES_PATH
+ ./install.scm ${SCSH_LAYOUT_CONF} \
+ --bindir /usr/bin \
+ --force \
+ || die "./install.scm failed"
+}