summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-10-19 16:50:29 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-10-19 16:50:29 +0200
commit6dbb026d478135132faf863ff5ebe31ee11146c4 (patch)
tree43bbbcac6ed9e26edb54e0317810f13237d1683e /app-shells/thefuck
parentdev-python/sdnotify: Version bump to 0.3.2 (diff)
downloadgentoo-6dbb026d478135132faf863ff5ebe31ee11146c4.tar.gz
gentoo-6dbb026d478135132faf863ff5ebe31ee11146c4.tar.bz2
gentoo-6dbb026d478135132faf863ff5ebe31ee11146c4.zip
app-shells/thefuck: Version bump to 3.24
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'app-shells/thefuck')
-rw-r--r--app-shells/thefuck/Manifest1
-rw-r--r--app-shells/thefuck/thefuck-3.24.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-shells/thefuck/Manifest b/app-shells/thefuck/Manifest
index ff75625daf88..0d77927195ff 100644
--- a/app-shells/thefuck/Manifest
+++ b/app-shells/thefuck/Manifest
@@ -1 +1,2 @@
DIST thefuck-3.23.tar.gz 1353847 SHA256 36b0af52219a56dc34bb085e75afa822c479c5c05b9393598effc2c1b3c5eb32 SHA512 893700fcec88d7c0070bdc1ea90309cb77ebd7e21895cc633e2d5d2f99a83117e182b8dd386abee97b96affce3126a745613612522b5c731c2e7ab7a162b3814 WHIRLPOOL 88c0d7ffcb4d9a902cba8a54bfbf5939daa2c9d573bc6b7b3c326504dd57345041987b4ee0da2b0f3aaa97f687e9ff143d8e3fffddb68b69e9f8768078bbc2e0
+DIST thefuck-3.24.tar.gz 1360450 SHA256 686867f264ee34d9287814dde0e9ca5debb322deeaf0ac6773ec06f823d7c0b4 SHA512 d4949ea723cf3b080f2fbe269d0cafe3d0266089fa8cc515b3b9376b2004c045be82716cd219741a60a0e99c20575adb92339a879467f709f7ca03dcc71a5c2d WHIRLPOOL 395eb03bf8ec1504909631a7e88e2761d7778742fb52d6fd567ee4c3c1ec9186726550dde23b2234a93064d6317065852236fb83fd4bfcdb733a4d2aa7cee2e8
diff --git a/app-shells/thefuck/thefuck-3.24.ebuild b/app-shells/thefuck/thefuck-3.24.ebuild
new file mode 100644
index 000000000000..59434fe1c280
--- /dev/null
+++ b/app-shells/thefuck/thefuck-3.24.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{3_4,3_5,3_6})
+
+inherit distutils-r1
+
+DESCRIPTION="Magnificent app which corrects your previous console command"
+HOMEPAGE="https://github.com/nvbn/thefuck"
+SRC_URI="https://github.com/nvbn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/pyte[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ sed -i -e "/import pip/s/^/#/" -e "/pip.__version__/,+3 s/^/#/" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ py.test || die
+}