summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2019-10-27 17:47:35 +0900
committerAkinori Hattori <hattya@gentoo.org>2019-10-27 17:47:35 +0900
commita9410b1a59a2aca2cb86613a16285ed399c6b56e (patch)
tree37c738cfb817f09f774652a2d87b22496045dcc0 /app-shells/yash
parentapp-i18n/canfep: amd64/x86 stable (diff)
downloadgentoo-a9410b1a59a2aca2cb86613a16285ed399c6b56e.tar.gz
gentoo-a9410b1a59a2aca2cb86613a16285ed399c6b56e.tar.bz2
gentoo-a9410b1a59a2aca2cb86613a16285ed399c6b56e.zip
app-shells/yash: new upstream release
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-shells/yash')
-rw-r--r--app-shells/yash/Manifest1
-rw-r--r--app-shells/yash/yash-2.49.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-shells/yash/Manifest b/app-shells/yash/Manifest
index 5664904530be..cf36c4106aca 100644
--- a/app-shells/yash/Manifest
+++ b/app-shells/yash/Manifest
@@ -1,2 +1,3 @@
DIST yash-2.47.tar.gz 1161675 BLAKE2B 8491d5f977b9e23071098016443e8384bc584b8b1160e84b725a2965d032d8b8f5a7ac8b16b1a1e62d808b0543650e0bc42ddc52806c5475a7ca9e26640e84aa SHA512 c9607990a1cf947f9cf294f818d9c6de314dca92a9f106dc65e8d0fdeb6ac91b21a394c711c4b8aabae33b60fc70b72dc9483b6ac48d4e3be3019501ebc26332
DIST yash-2.48.tar.xz 736280 BLAKE2B bbb7d2f723000bbb168ce8d354c27d80b350d5b5b1fc450987b8ff45a3d0f3c94986632ead5510de70b27689498cdc370bef8bbcdded66dc8d43061358c438b8 SHA512 51201a5bec24ebfb550d3e6b52114c83221d2e4b54cde577b76def1ccdd3476758ea2c8e1468047bcfccd6e8cdc3fc1d35d6c0dc8b7017c8d290c4aea66350f3
+DIST yash-2.49.tar.xz 740780 BLAKE2B 61fa2d2ab8a5f672cb21cc39c78f18076a4acd79d84fa2285bb35b03a697a58fa77584e5d66268dedbf69b5b2f2e00a7d2b6f6954ffa37a5e9fee3995851034b SHA512 99d98cfbe09aa746f2707217ecb506d8d5998df4a603ac276a8a67782fdcb3a7bd41fb34744f3834e319b0fdb0b1fd480cf9e2a4b835fec3e758280e13036db5
diff --git a/app-shells/yash/yash-2.49.ebuild b/app-shells/yash/yash-2.49.ebuild
new file mode 100644
index 000000000000..2a5af19fe466
--- /dev/null
+++ b/app-shells/yash/yash-2.49.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PLOCALES="en ja"
+
+inherit flag-o-matic l10n toolchain-funcs
+
+DESCRIPTION="Yash is a POSIX-compliant command line shell"
+HOMEPAGE="https://yash.osdn.jp/"
+SRC_URI="mirror://sourceforge.jp/${PN}/71638/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls test"
+
+RDEPEND="sys-libs/ncurses:=
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ test? ( sys-apps/ed )"
+
+src_configure() {
+ append-cflags -std=c99
+
+ sh ./configure \
+ --prefix="${EPREFIX}"/usr \
+ $(use_enable nls) \
+ CC=$(tc-getCC) \
+ LINGUAS="$(l10n_get_locales | sed "s/en/en@quot en@boldquot/")" \
+ || die
+}