summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-09-06 19:34:19 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-09-06 19:34:19 +0200
commit18d6da5929e63a008472ba774c584321db3deac1 (patch)
tree0786bedca4fd485a827d5b0447e2dced8e1b8b47 /app-shells/zsh-completions
parentapp-emulation/img: Version bump to 0.4.9 (diff)
downloadgentoo-18d6da5929e63a008472ba774c584321db3deac1.tar.gz
gentoo-18d6da5929e63a008472ba774c584321db3deac1.tar.bz2
gentoo-18d6da5929e63a008472ba774c584321db3deac1.zip
app-shells/zsh-completions: Version bump to 0.28.0
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'app-shells/zsh-completions')
-rw-r--r--app-shells/zsh-completions/Manifest1
-rw-r--r--app-shells/zsh-completions/zsh-completions-0.28.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-shells/zsh-completions/Manifest b/app-shells/zsh-completions/Manifest
index 215593ae352f..48d3d0464c85 100644
--- a/app-shells/zsh-completions/Manifest
+++ b/app-shells/zsh-completions/Manifest
@@ -1 +1,2 @@
DIST zsh-completions-0.27.0.tar.gz 218869 BLAKE2B 7214506be2100d596842988f946b0f25f9c434f31a6b1d66c40baa1ccf259f827be96011d790f41b85abecfcb0fc1e5d56a715ca80c9926a5fd6ccc779ab98b0 SHA512 1c25fce14117d6eb652e2d3bfb49e68baa9f7c5832031582ec8c3066b91f07491067ff887647177048b51146beda1bcac7080abf140ea5ef846fcdd8ac388b8c
+DIST zsh-completions-0.28.0.tar.gz 248600 BLAKE2B 406b8a91dc7d4471519444efdf2eedf644a696eea69c2e00f33fa61e71ca8cb34935f824f62e2d4312d5fd27fc25875d51b122b4f2d7cc8a1a16d9d46ce0e336 SHA512 744b2b02de2154b31548d12c73091e5d4ee501dc39552dd7d526c67908fb7f65c06074d799da7ebed3a8f62b532a1482ba74ed26239979b050dbede4be9986d5
diff --git a/app-shells/zsh-completions/zsh-completions-0.28.0.ebuild b/app-shells/zsh-completions/zsh-completions-0.28.0.ebuild
new file mode 100644
index 000000000000..b2f60fb0e802
--- /dev/null
+++ b/app-shells/zsh-completions/zsh-completions-0.28.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/zsh-users/zsh-completions.git"
+else
+ SRC_URI="https://github.com/zsh-users/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~sparc ~x86"
+fi
+
+DESCRIPTION="Additional completion definitions for Zsh"
+HOMEPAGE="https://github.com/zsh-users/zsh-completions"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="app-shells/zsh"
+
+src_install() {
+ insinto /usr/share/zsh/site-functions
+ doins src/_*
+}
+
+pkg_postinst() {
+ elog
+ elog "If you happen to compile your functions, you may need to delete"
+ elog "~/.zcompdump{,.zwc} and recompile to make the new completions available"
+ elog "to your shell."
+ elog
+}