summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-08-09 14:52:50 -0400
committerTim Harder <radhermit@gentoo.org>2017-08-09 14:58:52 -0400
commit86a207399d8e4abaf3a1a3999fbbce2cb068aa30 (patch)
treedf9eba704db160ffaaf164a67035bd750964f648 /app-shells/zsh
parentsys-apps/baselayout: fix version_is_at_least function typo (diff)
downloadgentoo-86a207399d8e4abaf3a1a3999fbbce2cb068aa30.tar.gz
gentoo-86a207399d8e4abaf3a1a3999fbbce2cb068aa30.tar.bz2
gentoo-86a207399d8e4abaf3a1a3999fbbce2cb068aa30.zip
app-shells/zsh: version bump to 5.4.1
Also, apply patch by Mike Gilbert to set PATH=${ROOTPATH} if EUID = 0; otherwise, leave it alone. Leave prefix as-is for now. Bug: https://bugs.gentoo.org/255695 Bug: https://bugs.gentoo.org/621334
Diffstat (limited to 'app-shells/zsh')
-rw-r--r--app-shells/zsh/Manifest2
-rw-r--r--app-shells/zsh/files/zprofile-241
-rw-r--r--app-shells/zsh/zsh-5.4.1.ebuild218
-rw-r--r--app-shells/zsh/zsh-9999.ebuild3
4 files changed, 263 insertions, 1 deletions
diff --git a/app-shells/zsh/Manifest b/app-shells/zsh/Manifest
index f5f22ca42b3e..72c3a8796c3f 100644
--- a/app-shells/zsh/Manifest
+++ b/app-shells/zsh/Manifest
@@ -6,3 +6,5 @@ DIST zsh-5.3-doc.tar.xz 3161944 SHA256 cdfc6c3f7235b13308af5316cfa87abb5f51b3ec7
DIST zsh-5.3.1-doc.tar.xz 3161408 SHA256 d51762fcb5699c332da8a4e404cb9eb8d5de8fa4e0235a08bcf252c915bda6ed SHA512 27f9d50094c21a77b36fe3309a9ab81a2ccf6570139b11038bbebe9fff2d0701f0bccf9163f5bf47d51ce7b978df621a4cb9089c33e9179a61636fcc94a9fb9c WHIRLPOOL 40d10cf9767a168f2619b0bed947d6a05a45bece6a5a5bd353422fef88ca267bf2f03f18f6ce9ee86def9219b13e3c8fa145f73c22bb3f9d786ee6eddd773953
DIST zsh-5.3.1.tar.xz 2928832 SHA256 fc886cb2ade032d006da8322c09a7e92b2309177811428b121192d44832920da SHA512 25f723c76d2779c3cb53de2e0dbb1163ec289f76282bec49757880d0ce32bf64a001a6b40c54c290d342aa09f92319af5c597bff99de8dbd1fc895c11836f304 WHIRLPOOL cdd62b5c144a7b416bb46b7a14ddc12f5e1ff133acc292abcdc94d402b2c0a6b57667f962cb808bdd52fdedd4b98fb5669327d1754183f242f29bdaea73747fc
DIST zsh-5.3.tar.xz 2928684 SHA256 76f82cfd5ce373cf799a03b6f395283f128430db49202e3e3f512fb5a19d6f8a SHA512 b34da1a062954ccb166b0a22fa48b0d08bdb8f50fd96cb391f04887c0bf416e771ceaa8af8fa7da2dc2e6f7c3ecce5c92c4e3bee21fd93e467849c8febc021b0 WHIRLPOOL 9d52e36528c2272e2de33144bd76ddb50e505ecc2dec13e332c9e9185be1e919b5f4276de052b0d558d5f809c0437d1a85491924a6febd143dcfced53c323c81
+DIST zsh-5.4.1-doc.tar.xz 3197560 SHA256 b8b1a40aeec852806ad2b74b0a0c534320bf517e2fe2a087c0c9d39e75dc29f1 SHA512 2cc2c87dd408fba68a483fb33323abb2d3ecd66c2f4042fd4e1cff13d83df819075f54ef72c9ab6dfc98638948653e4210f2b8c0ea5c40e3b993e93bd77ee8a0 WHIRLPOOL d279964f59386d9a4cecf53998bb90b5c99b9331a06641bbe352445f27f8d6868214ea257e238e3179bdda0a22e46d4716853209ae4f01ad232ffe7615dec785
+DIST zsh-5.4.1.tar.xz 2972824 SHA256 94cbd57508287e8faa081424509738d496f5f41e32ed890e3a5498ce05d3633b SHA512 c666c54b05e2707e3a3cf9a87a17863792f0c89ec14f5fdc85a3064f26249cfba42a2953bc76bb90205fb87a08c203a165a5240c9fd6c489c13d8cc82ee6e979 WHIRLPOOL efc33f3bfc79013dd51c4cde14c99fafe51ee18b69d2aaaa6d244d1cc3fe2845633edb9183bf2db0e6df02cc4329ca3d59e1dacba9328ed68c72f0e7b8dac35e
diff --git a/app-shells/zsh/files/zprofile-2 b/app-shells/zsh/files/zprofile-2
new file mode 100644
index 000000000000..9c4313c4494d
--- /dev/null
+++ b/app-shells/zsh/files/zprofile-2
@@ -0,0 +1,41 @@
+# @GENTOO_PORTAGE_EPREFIX@/etc/zsh/zprofile
+
+# Load environment settings from profile.env, which is created by
+# env-update from the files in /etc/env.d
+if [ -e "@GENTOO_PORTAGE_EPREFIX@"/etc/profile.env ] ; then
+ . "@GENTOO_PORTAGE_EPREFIX@"/etc/profile.env
+fi
+
+# You should override these in your ~/.zprofile (or equivalent) for per-user
+# settings. For system defaults, you can add a new file in /etc/profile.d/.
+export EDITOR=${EDITOR:-/bin/nano}
+export PAGER=${PAGER:-/usr/bin/less}
+
+# 077 would be more secure, but 022 is generally quite realistic
+umask 022
+
+# Set up PATH depending on whether we're root or a normal user.
+# There's no real reason to exclude sbin paths from the normal user,
+# but it can make tab-completion easier when they aren't in the
+# user's PATH to pollute the executable namespace.
+#
+# It is intentional in the following line to use || instead of -o.
+# This way the evaluation can be short-circuited and calling whoami is
+# avoided.
+if [ "$EUID" = "0" ] || [ "$USER" = "root" ] ; then
+ @ZSH_NOPREFIX@PATH="${ROOTPATH}"
+ @ZSH_PREFIX@PATH="@GENTOO_PORTAGE_EPREFIX@/usr/sbin:@GENTOO_PORTAGE_EPREFIX@/usr/bin:@GENTOO_PORTAGE_EPREFIX@/sbin:@GENTOO_PORTAGE_EPREFIX@/bin:${ROOTPATH}:/usr/sbin:/usr/bin:/sbin:/bin"
+@ZSH_PREFIX@else
+ @ZSH_PREFIX@PATH="@GENTOO_PORTAGE_EPREFIX@/usr/bin:@GENTOO_PORTAGE_EPREFIX@/bin:${PATH}:/usr/bin:/bin"
+fi
+export PATH
+unset ROOTPATH
+
+shopts=$-
+setopt nullglob
+for sh in "@GENTOO_PORTAGE_EPREFIX@"/etc/profile.d/*.sh ; do
+ [ -r "$sh" ] && . "$sh"
+done
+unsetopt nullglob
+set -$shopts
+unset sh shopts
diff --git a/app-shells/zsh/zsh-5.4.1.ebuild b/app-shells/zsh/zsh-5.4.1.ebuild
new file mode 100644
index 000000000000..8919a5c5da5a
--- /dev/null
+++ b/app-shells/zsh/zsh-5.4.1.ebuild
@@ -0,0 +1,218 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic prefix
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3 autotools
+ EGIT_REPO_URI="git://git.code.sf.net/p/zsh/code"
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ SRC_URI="http://www.zsh.org/pub/${P}.tar.xz
+ doc? ( http://www.zsh.org/pub/${P}-doc.tar.xz )"
+fi
+
+DESCRIPTION="UNIX Shell similar to the Korn shell"
+HOMEPAGE="http://www.zsh.org/"
+
+LICENSE="ZSH gdbm? ( GPL-2 )"
+SLOT="0"
+IUSE="caps debug doc examples gdbm maildir pcre static unicode"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.1:0=
+ static? ( >=sys-libs/ncurses-5.7-r4:0=[static-libs] )
+ caps? ( sys-libs/libcap )
+ pcre? (
+ >=dev-libs/libpcre-3.9
+ static? ( >=dev-libs/libpcre-3.9[static-libs] )
+ )
+ gdbm? ( sys-libs/gdbm )
+ !<sys-apps/baselayout-2.4.1
+"
+DEPEND="sys-apps/groff
+ ${RDEPEND}"
+PDEPEND="
+ examples? ( app-doc/zsh-lovers )
+"
+if [[ ${PV} == 9999* ]] ; then
+ DEPEND+=" app-text/yodl
+ doc? (
+ sys-apps/texinfo
+ app-text/texi2html
+ virtual/latex-base
+ )"
+fi
+
+src_prepare() {
+ if [[ ${PV} != 9999* ]]; then
+ # fix zshall problem with soelim
+ ln -s Doc man1 || die
+ mv Doc/zshall.1 Doc/zshall.1.soelim || die
+ soelim Doc/zshall.1.soelim > Doc/zshall.1 || die
+
+ # add openrc specific options for init.d completion
+ eapply "${FILESDIR}"/${PN}-5.3-init.d-gentoo.diff
+ fi
+
+ cp "${FILESDIR}"/zprofile-2 "${T}"/zprofile || die
+ eprefixify "${T}"/zprofile || die
+ if use prefix ; then
+ sed -i -e 's|@ZSH_PREFIX@||' -e '/@ZSH_NOPREFIX@/d' "${T}"/zprofile || die
+ else
+ sed -i -e 's|@ZSH_NOPREFIX@||' -e '/@ZSH_PREFIX@/d' -e 's|""||' "${T}"/zprofile || die
+ fi
+
+ eapply_user
+
+ if [[ ${PV} == 9999* ]] ; then
+ sed -i "/^VERSION=/s/=.*/=${PV}/" Config/version.mk || die
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ local myconf=()
+
+ if use static ; then
+ myconf+=( --disable-dynamic )
+ append-ldflags -static
+ fi
+ if use debug ; then
+ myconf+=(
+ --enable-zsh-debug
+ --enable-zsh-mem-debug
+ --enable-zsh-mem-warning
+ --enable-zsh-secure-free
+ --enable-zsh-hash-debug
+ )
+ fi
+
+ if [[ ${CHOST} == *-darwin* ]]; then
+ myconf+=( --enable-libs=-liconv )
+ append-ldflags -Wl,-x
+ fi
+
+ econf \
+ --bindir="${EPREFIX}"/bin \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --enable-etcdir="${EPREFIX}"/etc/zsh \
+ --enable-runhelpdir="${EPREFIX}"/usr/share/zsh/${PV%_*}/help \
+ --enable-fndir="${EPREFIX}"/usr/share/zsh/${PV%_*}/functions \
+ --enable-site-fndir="${EPREFIX}"/usr/share/zsh/site-functions \
+ --enable-function-subdirs \
+ --with-tcsetpgrp \
+ $(use_enable maildir maildir-support) \
+ $(use_enable pcre) \
+ $(use_enable caps cap) \
+ $(use_enable unicode multibyte) \
+ $(use_enable gdbm ) \
+ "${myconf[@]}"
+
+ if use static ; then
+ # compile all modules statically, see Bug #27392
+ # removed cap and curses because linking failes
+ sed -e "s,link=no,link=static,g" \
+ -e "/^name=zsh\/cap/s,link=static,link=no," \
+ -e "/^name=zsh\/curses/s,link=static,link=no," \
+ -i "${S}"/config.modules || die
+ if ! use gdbm ; then
+ sed -i '/^name=zsh\/db\/gdbm/s,link=static,link=no,' \
+ "${S}"/config.modules || die
+ fi
+ fi
+}
+
+src_compile() {
+ default
+
+ if [[ ${PV} == 9999* ]] && use doc ; then
+ emake -C Doc everything
+ fi
+}
+
+src_test() {
+ addpredict /dev/ptmx
+ local i
+ for i in C02cond.ztst V08zpty.ztst X02zlevi.ztst Y01completion.ztst Y02compmatch.ztst Y03arguments.ztst ; do
+ rm "${S}"/Test/${i} || die
+ done
+ emake check
+}
+
+src_install() {
+ emake DESTDIR="${D}" install $(usex doc "install.info" "")
+
+ insinto /etc/zsh
+ doins "${T}"/zprofile
+
+ keepdir /usr/share/zsh/site-functions
+ insinto /usr/share/zsh/${PV%_*}/functions/Prompts
+ newins "${FILESDIR}"/prompt_gentoo_setup-1 prompt_gentoo_setup
+
+ local i
+
+ # install miscellaneous scripts (bug #54520)
+ sed -e "s:/usr/local/bin/perl:${EPREFIX}/usr/bin/perl:g" \
+ -e "s:/usr/local/bin/zsh:${EPREFIX}/bin/zsh:g" \
+ -i {Util,Misc}/* || die
+ for i in Util Misc ; do
+ insinto /usr/share/zsh/${PV%_*}/${i}
+ doins ${i}/*
+ done
+
+ # install header files (bug #538684)
+ insinto /usr/include/zsh
+ doins config.h Src/*.epro
+ for i in Src/{zsh.mdh,*.h} ; do
+ sed -e 's@\.\./config\.h@config.h@' \
+ -e 's@#\(\s*\)include "\([^"]\+\)"@#\1include <zsh/\2>@' \
+ -i "${i}"
+ doins "${i}"
+ done
+
+ dodoc ChangeLog* META-FAQ NEWS README config.modules
+
+ if use doc ; then
+ pushd "${WORKDIR}/${PN}-${PV%_*}" >/dev/null
+ docinto html
+ dodoc Doc/*.html
+ insinto /usr/share/doc/${PF}
+ doins Doc/zsh.{dvi,pdf}
+ popd >/dev/null
+ fi
+
+ docinto StartupFiles
+ dodoc StartupFiles/z*
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ echo
+ elog "If you want to enable Portage completions and Gentoo prompt,"
+ elog "emerge app-shells/gentoo-zsh-completions and add"
+ elog " autoload -U compinit promptinit"
+ elog " compinit"
+ elog " promptinit; prompt gentoo"
+ elog "to your ~/.zshrc"
+ echo
+ elog "Also, if you want to enable cache for the completions, add"
+ elog " zstyle ':completion::complete:*' use-cache 1"
+ elog "to your ~/.zshrc"
+ echo
+ elog "Note that a system zprofile startup file is installed. This will override"
+ elog "PATH and possibly other variables that a user may set in ~/.zshenv."
+ elog "Custom PATH settings and similar overridden variables can be moved to ~/.zprofile"
+ elog "or other user startup files that are sourced after the system zprofile."
+ echo
+ elog "If PATH must be set in ~/.zshenv to affect things like non-login ssh shells,"
+ elog "one method is to use a separate path-setting file that is conditionally sourced"
+ elog "in ~/.zshenv and also sourced from ~/.zprofile. For more information, see the"
+ elog "zshenv example in ${EROOT}/usr/share/doc/${PF}/StartupFiles/."
+ echo
+ elog "See https://wiki.gentoo.org/wiki/Zsh/HOWTO for more introduction documentation."
+ echo
+ fi
+}
diff --git a/app-shells/zsh/zsh-9999.ebuild b/app-shells/zsh/zsh-9999.ebuild
index a2f821d3dbc2..8919a5c5da5a 100644
--- a/app-shells/zsh/zsh-9999.ebuild
+++ b/app-shells/zsh/zsh-9999.ebuild
@@ -30,6 +30,7 @@ RDEPEND="
static? ( >=dev-libs/libpcre-3.9[static-libs] )
)
gdbm? ( sys-libs/gdbm )
+ !<sys-apps/baselayout-2.4.1
"
DEPEND="sys-apps/groff
${RDEPEND}"
@@ -56,7 +57,7 @@ src_prepare() {
eapply "${FILESDIR}"/${PN}-5.3-init.d-gentoo.diff
fi
- cp "${FILESDIR}"/zprofile-1 "${T}"/zprofile || die
+ cp "${FILESDIR}"/zprofile-2 "${T}"/zprofile || die
eprefixify "${T}"/zprofile || die
if use prefix ; then
sed -i -e 's|@ZSH_PREFIX@||' -e '/@ZSH_NOPREFIX@/d' "${T}"/zprofile || die