summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-09-06 23:13:33 +0200
committerMichał Górny <mgorny@gentoo.org>2018-09-06 23:21:33 +0200
commit06cdf1ae527265a910bf5af70d85c7e0e354da4e (patch)
treed20f6288f47b2e0c53ac5ed4b9491ed65aee7c9f /app-shells
parentapp-shells/bash-completion: Clean old up (diff)
downloadgentoo-06cdf1ae527265a910bf5af70d85c7e0e354da4e.tar.gz
gentoo-06cdf1ae527265a910bf5af70d85c7e0e354da4e.tar.bz2
gentoo-06cdf1ae527265a910bf5af70d85c7e0e354da4e.zip
app-shells/bash-completion: Migrate to eapi7-ver
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash-completion/bash-completion-2.8.ebuild4
-rw-r--r--app-shells/bash-completion/bash-completion-9999.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/app-shells/bash-completion/bash-completion-2.8.ebuild b/app-shells/bash-completion/bash-completion-2.8.ebuild
index 13232e470d60..cd66da677fd9 100644
--- a/app-shells/bash-completion/bash-completion-2.8.ebuild
+++ b/app-shells/bash-completion/bash-completion-2.8.ebuild
@@ -4,7 +4,7 @@
EAPI=6
BASHCOMP_P=bashcomp-2.0.2
-inherit versionator
+inherit eapi7-ver
DESCRIPTION="Programmable Completion for bash"
HOMEPAGE="https://github.com/scop/bash-completion"
@@ -112,7 +112,7 @@ src_install() {
pkg_postinst() {
local v
for v in ${REPLACING_VERSIONS}; do
- if ! version_is_at_least 2.1-r90 ${v}; then
+ if ver_test "${v}" -lt 2.1-r90; then
ewarn "For bash-completion autoloader to work, all completions need to"
ewarn "be installed in /usr/share/bash-completion/completions. You may"
ewarn "need to rebuild packages that installed completions in the old"
diff --git a/app-shells/bash-completion/bash-completion-9999.ebuild b/app-shells/bash-completion/bash-completion-9999.ebuild
index 1ef70643b1e9..79ee3e0ac0af 100644
--- a/app-shells/bash-completion/bash-completion-9999.ebuild
+++ b/app-shells/bash-completion/bash-completion-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=6
BASHCOMP_P=bashcomp-2.0.2
EGIT_REPO_URI="https://github.com/scop/bash-completion"
-inherit autotools git-r3 versionator
+inherit autotools eapi7-ver git-r3
DESCRIPTION="Programmable Completion for bash"
HOMEPAGE="https://github.com/scop/bash-completion"
@@ -112,7 +112,7 @@ src_install() {
pkg_postinst() {
local v
for v in ${REPLACING_VERSIONS}; do
- if ! version_is_at_least 2.1-r90 ${v}; then
+ if ver_test "${v}" -lt 2.1-r90; then
ewarn "For bash-completion autoloader to work, all completions need to"
ewarn "be installed in /usr/share/bash-completion/completions. You may"
ewarn "need to rebuild packages that installed completions in the old"