summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-02-14 09:34:24 +0100
committerMichał Górny <mgorny@gentoo.org>2016-02-14 09:36:44 +0100
commit0fcfd1c1aef0e9cb736d97bbd848dd922c67ce85 (patch)
tree221e73393425ce0d7a2941bd156c1e8a72a792b4 /app-shells
parentwww-apps/nanoc: add 4.1.4 (diff)
downloadgentoo-0fcfd1c1aef0e9cb736d97bbd848dd922c67ce85.tar.gz
gentoo-0fcfd1c1aef0e9cb736d97bbd848dd922c67ce85.tar.bz2
gentoo-0fcfd1c1aef0e9cb736d97bbd848dd922c67ce85.zip
app-shells/posh: Version bump to 0.12.5
Bump to 0.12.5 that has a few bugfixes, gcc5 build fix most notably (#546642).
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/posh/Manifest1
-rw-r--r--app-shells/posh/posh-0.12.5.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-shells/posh/Manifest b/app-shells/posh/Manifest
index c9413d579a6f..3545e9802452 100644
--- a/app-shells/posh/Manifest
+++ b/app-shells/posh/Manifest
@@ -1 +1,2 @@
+DIST posh_0.12.5.tar.xz 267356 SHA256 adf1b5670b9978c3b6d5ae64356be72d8c31db1750a7600ff981fec3ff920a0a SHA512 03fabb32eb2cd38b90cf4bef641a9ce35e3e79a65b22bf6c8654b0da9d05385efe1fb5c0274deba9c616c7aba443f9a408194a066983edf051be1098be11f21e WHIRLPOOL 7a6275c14818cc24085e9383e9fce51dbb71ebdb001af2a7f5bc061a807e4681f83f57a6a2aa5bac4655d8f24466e9a7f0e573c584d04e660a668995d0144b8f
DIST posh_0.12.tar.gz 469680 SHA256 9206b67005cf357404b3f3021c2d7c7bbd50756050512dececb9ed836435b048 SHA512 bb98d2fa009b5ccd666103378dd30da5649baf830d4e3124575f813b98b13275bde46e03bb737c75b37c82f655b3f17e9a5decd29b75d20678e78a4d7e3abf00 WHIRLPOOL ffd03e1537aa8e68545c532fb8c27fc9702ab16157efce7ef5c83b6f70fbe1a807e4759b85525036ae0c26f56b595ccf95d9cffb8a96b4ef8e5a8ec4b50c60e6
diff --git a/app-shells/posh/posh-0.12.5.ebuild b/app-shells/posh/posh-0.12.5.ebuild
new file mode 100644
index 000000000000..fe95f2cc4cf9
--- /dev/null
+++ b/app-shells/posh/posh-0.12.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Reimplementation of Bourne shell based on pdksh"
+HOMEPAGE="http://packages.debian.org/posh"
+SRC_URI="mirror://debian/pool/main/p/posh/${P/-/_}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="app-arch/xz-utils"
+
+# Tests fails looking for some 'getopts.pl'
+RESTRICT="test"
+
+src_prepare() {
+ default
+
+ # tarball bundles outdated generated files
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --exec-prefix=/
+ )
+ econf "${myconf[@]}"
+}