summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2023-01-12 23:05:14 +0100
committerPatrice Clement <monsieurp@gentoo.org>2023-01-12 23:05:14 +0100
commit30d958a39aa1346054076799595f78004132c91e (patch)
tree83572b90f63336a933c6e5b39f86f3c89c24e758 /app-shells
parentmedia-libs/libsixel: Keyword 1.10.3 ppc64, #885397 (diff)
downloadgentoo-30d958a39aa1346054076799595f78004132c91e.tar.gz
gentoo-30d958a39aa1346054076799595f78004132c91e.tar.bz2
gentoo-30d958a39aa1346054076799595f78004132c91e.zip
app-shells/hstr: add 2.6
Closes: https://bugs.gentoo.org/872494 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/hstr/Manifest1
-rw-r--r--app-shells/hstr/hstr-2.6.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-shells/hstr/Manifest b/app-shells/hstr/Manifest
index 4f064c3839a1..e9e1c385dc34 100644
--- a/app-shells/hstr/Manifest
+++ b/app-shells/hstr/Manifest
@@ -1 +1,2 @@
DIST hstr-2.2.tar.gz 1246786 BLAKE2B f14091fea391dada79798c957b0b1094aff73b7ab4f8d9fd53c1070924556a7ff59f6f5a2e49b36dcd46ca6f93c5f8cd0fcfef07d5f7458d4bbe021546ccdc7a SHA512 c133edaa63a2be76356c08e52303d4133b11803e3ac6f915566a8d1b4651991b14d43974618061b2fc98c49e21b650ff6b9ac8168512e76566e327f90a550e4a
+DIST hstr-2.6.tar.gz 1249557 BLAKE2B 147ec4a0db98444bce2e9abcd0d6105dc777b52848d831b9df13ad1d897e372b891de1cb3fd2b43c4f046144214903f6d391955ad9699017805538377d5786dc SHA512 5b9a6f2ce1914dad2f245148e5b8e10d98abc7e5830118686693790a6d8a3e4c1acaea7b9ed3841467e43f2a3ee34d6d4a114c116a049595178fef2272ed8f54
diff --git a/app-shells/hstr/hstr-2.6.ebuild b/app-shells/hstr/hstr-2.6.ebuild
new file mode 100644
index 000000000000..6a4a7749524a
--- /dev/null
+++ b/app-shells/hstr/hstr-2.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Shell history suggest box"
+HOMEPAGE="https://github.com/dvorka/hstr http://www.mindforger.com"
+SRC_URI="https://github.com/dvorka/hstr/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ sys-libs/ncurses:=[unicode(+)]"
+
+DEPEND="
+ ${RDEPEND}"
+
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( CONFIGURATION.md README.md )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0-fix-ncurses-configure.patch
+)
+
+src_prepare() {
+ default
+
+ sed \
+ -e 's:-O2::g' \
+ -i src/Makefile.am || die
+
+ tc-export PKG_CONFIG
+
+ eautoreconf
+}