summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-12 13:12:43 +0100
committerSam James <sam@gentoo.org>2023-10-12 13:13:02 +0100
commit31d30791ea6ace369259757da891a56ed1267a9c (patch)
tree8b884bd4b048eb0842400a7b6a8385fe55f91f3e /app-shells
parentapp-arch/xz-utils: tidy up PGO bits (diff)
downloadgentoo-31d30791ea6ace369259757da891a56ed1267a9c.tar.gz
gentoo-31d30791ea6ace369259757da891a56ed1267a9c.tar.bz2
gentoo-31d30791ea6ace369259757da891a56ed1267a9c.zip
app-shells/bash: tidy up PGO bits
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/bash-5.2_p15-r7.ebuild2
-rw-r--r--app-shells/bash/bash-9999.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/app-shells/bash/bash-5.2_p15-r7.ebuild b/app-shells/bash/bash-5.2_p15-r7.ebuild
index af96b44e4a86..a80bdd6357a4 100644
--- a/app-shells/bash/bash-5.2_p15-r7.ebuild
+++ b/app-shells/bash/bash-5.2_p15-r7.ebuild
@@ -260,7 +260,7 @@ src_compile() {
# -fprofile-partial-training because upstream note the test suite isn't super comprehensive
# See https://documentation.suse.com/sbp/all/html/SBP-GCC-10/index.html#sec-gcc10-pgo
local pgo_generate_flags=$(usev pgo "-fprofile-update=atomic -fprofile-dir=${T}/pgo -fprofile-generate=${T}/pgo $(test-flags-CC -fprofile-partial-training)")
- local pgo_use_flags=$(usev pgo "-fprofile-use=${T}/pgo -fprofile-dir=${T}/pgo")
+ local pgo_use_flags=$(usev pgo "-fprofile-use=${T}/pgo -fprofile-dir=${T}/pgo $(test-flags-CC -fprofile-partial-training)")
emake CFLAGS="${CFLAGS} ${pgo_generate_flags}"
use plugins && emake -C examples/loadables CFLAGS="${CFLAGS} ${pgo_generate_flags}" all others
diff --git a/app-shells/bash/bash-9999.ebuild b/app-shells/bash/bash-9999.ebuild
index e2a0d09d841b..6e86e0d185f3 100644
--- a/app-shells/bash/bash-9999.ebuild
+++ b/app-shells/bash/bash-9999.ebuild
@@ -257,7 +257,7 @@ src_compile() {
# -fprofile-partial-training because upstream note the test suite isn't super comprehensive
# See https://documentation.suse.com/sbp/all/html/SBP-GCC-10/index.html#sec-gcc10-pgo
local pgo_generate_flags=$(usev pgo "-fprofile-update=atomic -fprofile-dir=${T}/pgo -fprofile-generate=${T}/pgo $(test-flags-CC -fprofile-partial-training)")
- local pgo_use_flags=$(usev pgo "-fprofile-use=${T}/pgo -fprofile-dir=${T}/pgo")
+ local pgo_use_flags=$(usev pgo "-fprofile-use=${T}/pgo -fprofile-dir=${T}/pgo $(test-flags-CC -fprofile-partial-training)")
emake CFLAGS="${CFLAGS} ${pgo_generate_flags}"
use plugins && emake -C examples/loadables CFLAGS="${CFLAGS} ${pgo_generate_flags}" all others