summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-08-17 23:31:12 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-08-17 23:31:12 +0200
commit49bd71bec1ca1b7116a297c48ae8f01469859768 (patch)
treef4b981e8429f115b635d8f6b74662cf32a2d8fc4 /app-shells
parentmedia-gfx/digikam: Drop old (diff)
downloadgentoo-49bd71bec1ca1b7116a297c48ae8f01469859768.tar.gz
gentoo-49bd71bec1ca1b7116a297c48ae8f01469859768.tar.bz2
gentoo-49bd71bec1ca1b7116a297c48ae8f01469859768.zip
app-shells/thefuck: Version bump to 3.11
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/thefuck/Manifest1
-rw-r--r--app-shells/thefuck/thefuck-3.11.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-shells/thefuck/Manifest b/app-shells/thefuck/Manifest
index 91104e956b5d..678519d6b9ae 100644
--- a/app-shells/thefuck/Manifest
+++ b/app-shells/thefuck/Manifest
@@ -1 +1,2 @@
DIST thefuck-3.10.tar.gz 786180 SHA256 4cdad2040325f73918f00e65822ce21c202e178173606452ed0c730d8c447210 SHA512 fa77177388e311834d5cae9e6264eebaf1b7e52f90a5fa5fd4c3a1858448c4a3288fabd7f08e604b81db1f759f25e7c0403e21ed9772ec517f2f8e8a5163441f WHIRLPOOL cb488dce6d0fa4ec5c760120f908eedf062933d3fb84643e83ef13d6fc29178085b6f960a97cbcd8b38500cec373cdda6a10bee77433f5aa76aa672bf7adf3bf
+DIST thefuck-3.11.tar.gz 796095 SHA256 77ee25d0da7c3b5e373c2811c3a4d625de4c635094e960b9f9c60dc490650213 SHA512 774041c5bb54457add90ed071555a0f6215f43501e9ad359af4e1525df34daa3d35de17ccc93f0c74985c107560c0f86e2db52d58265c4f78d31c69015359631 WHIRLPOOL 5eaf7e56100f601146ffd19090463c132ec66a9fcf71340979094df04d8179ddc6624a3c420c114c330e7fafcfbcaeebc1bca462382368a289b75d606f581698
diff --git a/app-shells/thefuck/thefuck-3.11.ebuild b/app-shells/thefuck/thefuck-3.11.ebuild
new file mode 100644
index 000000000000..b841c8c566e4
--- /dev/null
+++ b/app-shells/thefuck/thefuck-3.11.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python{2_7,3_4})
+
+inherit distutils-r1
+
+DESCRIPTION="Magnificent app which corrects your previous console command"
+HOMEPAGE="https://github.com/nvbn/thefuck"
+SRC_URI="https://github.com/nvbn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="dev-python/pathlib[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ sed -i -e "/import pip/s/^/#/" -e "/pip.__version__/,+3 s/^/#/" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ py.test || die
+}