summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-09-04 16:03:47 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-09-04 16:04:22 +0200
commit56008b715e79867a6341e5009519365fa3f89259 (patch)
tree3fc320df23d870e2e4185ac1ee61a7f3da92a98c /app-shells
parentsci-libs/xdmf2: Call 'python_optimize' only when USE=python (diff)
downloadgentoo-56008b715e79867a6341e5009519365fa3f89259.tar.gz
gentoo-56008b715e79867a6341e5009519365fa3f89259.tar.bz2
gentoo-56008b715e79867a6341e5009519365fa3f89259.zip
app-shells/thefuck: Fix dependencies for python2.7
Gentoo-Bug: 589110 Package-Manager: portage-2.3.0
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/thefuck/thefuck-3.11-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-shells/thefuck/thefuck-3.11-r1.ebuild b/app-shells/thefuck/thefuck-3.11-r1.ebuild
new file mode 100644
index 000000000000..e1d61c720d9f
--- /dev/null
+++ b/app-shells/thefuck/thefuck-3.11-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python{2_7,3_4})
+
+inherit distutils-r1
+
+DESCRIPTION="Magnificent app which corrects your previous console command"
+HOMEPAGE="https://github.com/nvbn/thefuck"
+SRC_URI="https://github.com/nvbn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="virtual/python-pathlib[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' python2_7)"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ sed -i -e "/import pip/s/^/#/" -e "/pip.__version__/,+3 s/^/#/" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ py.test || die
+}