summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-03-13 00:40:09 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-03-13 00:40:09 +0100
commit62fc27f2328fb506f4cdc8330864023bac1d581c (patch)
tree31cc0f9ec4479abe140bb9bd2f63e776d81f2a0b /app-shells
parentdev-python/keyring: bup (diff)
downloadgentoo-62fc27f2328fb506f4cdc8330864023bac1d581c.tar.gz
gentoo-62fc27f2328fb506f4cdc8330864023bac1d581c.tar.bz2
gentoo-62fc27f2328fb506f4cdc8330864023bac1d581c.zip
app-shells/thefuck: Initial version
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/thefuck/Manifest1
-rw-r--r--app-shells/thefuck/metadata.xml11
-rw-r--r--app-shells/thefuck/thefuck-3.4.ebuild30
3 files changed, 42 insertions, 0 deletions
diff --git a/app-shells/thefuck/Manifest b/app-shells/thefuck/Manifest
new file mode 100644
index 000000000000..36cee96d4bfa
--- /dev/null
+++ b/app-shells/thefuck/Manifest
@@ -0,0 +1 @@
+DIST thefuck-3.4.tar.gz 781871 SHA256 ce98f6219e64b6e9e9f2cad22fa1bac121a5d79f3a530d9b2cb8bc61a629904f SHA512 8d78a91d3320230fbd47bdd79ad352bf7b5c9bc2f7d41bd8382177e650f9e01d1660c0620e443a3bb7e36c193c73ea3aaaab5f2e5bc1b469b8d919602b8c1d4f WHIRLPOOL 44408d18caae4c41e51360cdce720d2514f4288fbc2a70f7894718b2c14caa9c0baa7df3d28501e3421be2ff7e69a7293f2b4822003e1f7cacbaa55a1b1e8b78
diff --git a/app-shells/thefuck/metadata.xml b/app-shells/thefuck/metadata.xml
new file mode 100644
index 000000000000..f7e2bc9ec43e
--- /dev/null
+++ b/app-shells/thefuck/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">nvbn/thefuck</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-shells/thefuck/thefuck-3.4.ebuild b/app-shells/thefuck/thefuck-3.4.ebuild
new file mode 100644
index 000000000000..d75c92f688f6
--- /dev/null
+++ b/app-shells/thefuck/thefuck-3.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python{2_7,3_4})
+
+inherit distutils-r1
+
+DESCRIPTION="Magnificent app which corrects your previous console command"
+HOMEPAGE="https://github.com/nvbn/thefuck"
+SRC_URI="https://github.com/nvbn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="dev-python/pathlib[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ py.test || die
+}