summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-12-08 09:59:40 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-12-08 10:16:15 +0000
commit730fa101e33ff67aea3c615286f20412b7dda491 (patch)
tree7aac743cb63821d9c4828d64b0f87fa113d9b621 /app-shells
parentdev-java/commons-lang: EAPI 5 bump. (diff)
downloadgentoo-730fa101e33ff67aea3c615286f20412b7dda491.tar.gz
gentoo-730fa101e33ff67aea3c615286f20412b7dda491.tar.bz2
gentoo-730fa101e33ff67aea3c615286f20412b7dda491.zip
app-shells/hstr: Version bump.
Package-Manager: portage-2.2.20.1 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/hstr/Manifest1
-rw-r--r--app-shells/hstr/files/hstr-1.18-tinfo.patch47
-rw-r--r--app-shells/hstr/hstr-1.18.ebuild32
3 files changed, 80 insertions, 0 deletions
diff --git a/app-shells/hstr/Manifest b/app-shells/hstr/Manifest
index 1e136474aea0..b11e1145bef2 100644
--- a/app-shells/hstr/Manifest
+++ b/app-shells/hstr/Manifest
@@ -1 +1,2 @@
DIST hstr-1.17.tar.gz 37289 SHA256 9e4b6e74bb7852945e25727105c5339c49c9ce1218481845c8d0205514d85e70 SHA512 eb89496c8554eb29ebb30430aa01179f7265a8ec15b0b9452f7e3ac4867ae4349e6141e11f0af01a4d15ba06131c18ec9ab760c8e68100fa2b8f2a793b237f9b WHIRLPOOL 2b33f485525b2cb033a82b249976d7c670d8f02948e84e73f350b19bdc955e551014f14ad4cfc845144ff0e0d8c3690c50b4444a414c7909f0106242d13a9cc2
+DIST hstr-1.18.tar.gz 43672 SHA256 85eb071938c2e7314e5fbd245a81c7b0cd93a8864bf9cba5b5041acb5052ba73 SHA512 e0684a694a514a341c30bfa7fc596f858658f3be9db6c490f628b4c48d1bf08acd8b4b03361ceb6aef65d42a5b01a1c0a8ce94698b5f7f5193ef030d7dc896c4 WHIRLPOOL 1bd00be28623ea8e05c1cec3d95451b7f92e6b17bfb5bd2853560955fc5ace9226edefdee820e9cee6c3542180f699b56371b9766a65a8efc669987dd5e961fb
diff --git a/app-shells/hstr/files/hstr-1.18-tinfo.patch b/app-shells/hstr/files/hstr-1.18-tinfo.patch
new file mode 100644
index 000000000000..0ffbd0cff257
--- /dev/null
+++ b/app-shells/hstr/files/hstr-1.18-tinfo.patch
@@ -0,0 +1,47 @@
+diff --git a/configure.ac b/configure.ac
+index 9cf6a53..cbc649d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -18,17 +18,21 @@ AC_PROG_CC
+
+ # Platform specific ncurses check.
+ AC_CANONICAL_HOST
+-AS_CASE([$host_os],
+- [darwin*],
+- [
+- AC_CHECK_LIB(ncurses, killwchar, [], [AC_MSG_ERROR([Could not find ncurses library])])
+- AC_CHECK_HEADER(curses.h)
+- ],
+- [
+- AC_CHECK_LIB(ncursesw, killwchar, [], [AC_MSG_ERROR([Could not find ncursesw library])])
+- AC_CHECK_HEADER(ncursesw/curses.h)
+- ]
+-)
++PKG_CHECK_MODULES([NCURSES], [ncursesw], [], [
++ PKG_CHECK_MODULES([NCURSES], [ncurses], [], [
++ AS_CASE([$host_os],
++ [darwin*],
++ [
++ AC_CHECK_LIB(ncurses, killwchar, [], [AC_MSG_ERROR([Could not find ncurses library])])
++ AC_CHECK_HEADER(curses.h)
++ ],
++ [
++ AC_CHECK_LIB(ncursesw, killwchar, [], [AC_MSG_ERROR([Could not find ncursesw library])])
++ AC_CHECK_HEADER(ncursesw/curses.h)
++ ]
++ )
++ ])
++])
+
+ # Checks for libraries.
+ AC_CHECK_LIB(m, cos, [], [AC_MSG_ERROR([Could not find m library])])
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 5765613..ee411a9 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -15,3 +15,5 @@ hh_SOURCES = \
+ hstr_regexp.c include/hstr_regexp.h \
+ radixsort.c include/radixsort.h \
+ hstr.c
++
++hh_LDADD = $(NCURSES_LIBS)
diff --git a/app-shells/hstr/hstr-1.18.ebuild b/app-shells/hstr/hstr-1.18.ebuild
new file mode 100644
index 000000000000..57a6535441f2
--- /dev/null
+++ b/app-shells/hstr/hstr-1.18.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
+
+DESCRIPTION="Shell history suggest box - easily view, navigate, search and manage your command history"
+HOMEPAGE="https://github.com/dvorka/hstr http://www.mindforger.com"
+SRC_URI="https://github.com/dvorka/hstr/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86 ~ppc ~ppc64 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+DOCS=( CONFIGURATION.md README.md )
+
+src_prepare() {
+ sed \
+ -e 's:-O2::g' \
+ -i src/Makefile.am || die
+ autotools-utils_src_prepare
+}