summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-02-19 14:26:56 +0100
committerMichał Górny <mgorny@gentoo.org>2016-02-19 14:41:39 +0100
commit79f27cc2135d1dc52bf8e0214c6b864ca4cf4657 (patch)
tree73ef24758fdb7b8dfe3c591f6f45565651cb8f7d /app-shells
parentapp-editors/tea: remove old (diff)
downloadgentoo-79f27cc2135d1dc52bf8e0214c6b864ca4cf4657.tar.gz
gentoo-79f27cc2135d1dc52bf8e0214c6b864ca4cf4657.tar.bz2
gentoo-79f27cc2135d1dc52bf8e0214c6b864ca4cf4657.zip
app-shells/bash-completion: Fix blacklist/whitelist matching, #574570
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash-completion/Manifest1
-rw-r--r--app-shells/bash-completion/bash-completion-2.1_p20141224-r2.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/app-shells/bash-completion/Manifest b/app-shells/bash-completion/Manifest
index 122e9b0264e7..517a2b342068 100644
--- a/app-shells/bash-completion/Manifest
+++ b/app-shells/bash-completion/Manifest
@@ -2,4 +2,5 @@ DIST bash-completion-1.3.tar.bz2 211899 SHA256 8ebe30579f0f3e1a521013bcdd1831936
DIST bash-completion-2.1.tar.bz2 265329 SHA256 2b606804a7d5f823380a882e0f7b6c8a37b0e768e72c3d4107c51fbe8a46ae4f SHA512 0bc71039ef136b1ccb72527eb40f2ed4068a58dc31b1ac1ee52a40e7c950ea4cfbb4f1bee2f0da6774e56062578fa3653096e6d306eea7f028dd55ff737e92fe WHIRLPOOL 0275d8ac99a0ac5b12637bf2b13561d656b239ba7c166071cb283a481df2fdd904ad1c18608ea35b9af4f0f4db3b034f833f0fd586a0096626d1b268bcd8fc00
DIST bash-completion-2.1_p20141224.tar.xz 257964 SHA256 a76ffdbc9f49f48e290f0e6f3d46060d51c770f91e25b35b014bc16fec76f517 SHA512 94649aad8dbf0f170422605a5f36c5cab61e45ce402a92f89a6eba3bd5d2e976087b35cd0a9b6d4d29ba608cee3bb27b692088c884b766447ee9eafa99c2814a WHIRLPOOL 0ea12dfc8f432ffed598aee65c7080de570ebe9783415c7ebe4bd5d152fc645a132fae3a28986c029d13a4b939e15053204d73ae9b207f4ad62b9c117bf59cba
DIST bashcomp-2.0.1.tar.bz2 4078 SHA256 142348b61b32fb3f1580ac90b684b1014d6d177f371baadb503340c507f9a992 SHA512 8ac8982f418a2d71dffcf027ffe0b7eefa3ee49413a726a8ee9e758975d8f86c687a64b55cd94e09b7936d1c6990285ddc90a3c2b1989af44322937c5c4fb8d7 WHIRLPOOL b6daa0a93282e9df73635cbdddde97c473fd22aa3baf035c3ffcb5966152e20b26d85979fe8a5ecf9128157422f3f60dc27c82c843b9a0e6e80b7de7da596250
+DIST bashcomp-2.0.2.tar.gz 3625 SHA256 6ede58bfbe99f0dca1eb9236492aa20a6755e5731526de56e15d1e2b220165c9 SHA512 46bc1bcc32263135f44be68569459a409250dd2c81c18190735f11e13a26508e9d3cb91d24a8fe7b21bdea678347873b7ac1b67d5e8c78c8444011f85dfdcdce WHIRLPOOL 4b6cb989235d5fed8fd9986c1419ab337df38384fe2b307fd78f08f8696f4a2328845ed4f27913a36e9a544e973690bc0dd2af73816e272c3faf27ff2eafa585
DIST bashcomp2-pre1.tar.gz 3732 SHA256 fd201638bae06f134c243887cafe402ef0a21f9e62cca3966f405c249abc9eec SHA512 745801fe20c846cb0cdb044d712caacd75a2902c9dddc2261bdb179dcd826e5d1032d6b1f73340abe74dbb82d29b4386897291ccdf45d9bbd1fdb80a5f79fa45 WHIRLPOOL eb529c7263653b3e3e36c0cf29d44c57ce64bb2144f06ff7f2df569dd2ae66eb135b2ace5542c37cb100da8b3562b32ab61bcd9f5fd3cfbf67febf5e5086e04a
diff --git a/app-shells/bash-completion/bash-completion-2.1_p20141224-r2.ebuild b/app-shells/bash-completion/bash-completion-2.1_p20141224-r2.ebuild
new file mode 100644
index 000000000000..846afc842d65
--- /dev/null
+++ b/app-shells/bash-completion/bash-completion-2.1_p20141224-r2.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+BASHCOMP_P=bashcomp-2.0.2
+inherit versionator
+
+DESCRIPTION="Programmable Completion for bash"
+HOMEPAGE="http://bash-completion.alioth.debian.org/"
+SRC_URI="https://dev.gentoo.org/~mgorny/dist/${P}.tar.xz
+ https://bitbucket.org/mgorny/bashcomp2/downloads/${BASHCOMP_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris"
+IUSE=""
+
+RDEPEND=">=app-shells/bash-4.3_p30-r1
+ sys-apps/miscfiles
+ !app-eselect/eselect-bashcomp"
+DEPEND="app-arch/xz-utils"
+PDEPEND=">=app-shells/gentoo-bashcomp-20140911"
+
+# Remove unwanted completions.
+STRIP_COMPLETIONS=(
+ # Slackware package stuff, quite generic names cause collisions
+ # (e.g. with sys-apps/pacman)
+ explodepkg installpkg makepkg pkgtool removepkg upgradepkg
+
+ # Debian/Red Hat network stuff
+ ifdown ifup ifstatus
+
+ # Installed in app-editors/vim-core
+ xxd
+
+ # Now-dead symlinks to deprecated completions
+ hd ncal
+)
+
+src_prepare() {
+ epatch "${WORKDIR}/${BASHCOMP_P}/${P}"-*.patch
+ # Bug 543100
+ epatch "${FILESDIR}/${PN}-2.1-escape-characters.patch"
+}
+
+src_test() { :; } # Skip testsuite because of interactive shell wrt #477066
+
+src_install() {
+ # work-around race conditions, bug #526996
+ mkdir -p "${ED}"/usr/share/bash-completion/{completions,helpers} || die
+
+ emake DESTDIR="${D}" profiledir="${EPREFIX}"/etc/bash/bashrc.d install
+
+ local file
+ for file in "${STRIP_COMPLETIONS[@]}"; do
+ rm "${ED}"/usr/share/bash-completion/completions/${file} || die
+ done
+ # remove deprecated completions (moved to other packages)
+ rm "${ED}"/usr/share/bash-completion/completions/_* || die
+
+ dodoc AUTHORS CHANGES README
+
+ # install the eselect module
+ insinto /usr/share/eselect/modules
+ doins "${WORKDIR}/${BASHCOMP_P}/bashcomp.eselect"
+ doman "${WORKDIR}/${BASHCOMP_P}/bashcomp.eselect.5"
+}
+
+pkg_postinst() {
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if ! version_is_at_least 2.1-r90 ${v}; then
+ ewarn "For bash-completion autoloader to work, all completions need to"
+ ewarn "be installed in /usr/share/bash-completion/completions. You may"
+ ewarn "need to rebuild packages that installed completions in the old"
+ ewarn "location. You can do this using:"
+ ewarn
+ ewarn "$ find ${EPREFIX}/usr/share/bash-completion -maxdepth 1 -type f '!' -name 'bash_completion' -exec emerge -1v {} +"
+ ewarn
+ ewarn "After the rebuild, you should remove the old setup symlinks:"
+ ewarn
+ ewarn "$ find ${EPREFIX}/etc/bash_completion.d -type l -delete"
+ fi
+ done
+
+ if has_version 'app-shells/zsh'; then
+ elog
+ elog "If you are interested in using the provided bash completion functions with"
+ elog "zsh, valuable tips on the effective use of bashcompinit are available:"
+ elog " http://www.zsh.org/mla/workers/2003/msg00046.html"
+ elog
+ fi
+}