summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-02-27 10:42:41 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-02-27 10:42:41 +0100
commit8cca793290fcddc2d1f60ffcf2361f13f5505e09 (patch)
treeed31eac92efca2ab85e9b39ba898fa944998b16b /app-shells
parentdev-util/jenkins-bin: Remove vulnerable (diff)
downloadgentoo-8cca793290fcddc2d1f60ffcf2361f13f5505e09.tar.gz
gentoo-8cca793290fcddc2d1f60ffcf2361f13f5505e09.tar.bz2
gentoo-8cca793290fcddc2d1f60ffcf2361f13f5505e09.zip
app-shells/zsh-completions: Version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/zsh-completions/Manifest1
-rw-r--r--app-shells/zsh-completions/zsh-completions-0.16.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-shells/zsh-completions/Manifest b/app-shells/zsh-completions/Manifest
index f14f84c10a42..e89f21410c15 100644
--- a/app-shells/zsh-completions/Manifest
+++ b/app-shells/zsh-completions/Manifest
@@ -1,2 +1,3 @@
DIST zsh-completions-0.14.0.tar.gz 199317 SHA256 54e4f5aad66acd729c46f589dc0b9f2a518b453892e4c21e495f33bb959c7eef SHA512 fd2fa683c5990fba9dfa12e839d70c24b7821b487175f5c51d603d21a494f7e9e921628fdd8fff1c02f8c2f52ac1fba1f48638da6a356240e0b7806c1b747ec2 WHIRLPOOL 28df4d93c0bf80bd5c3bb2c189897042e0cfd99fef77492adfe410dca96e140a8e654c0a896b45991f3605822a209d6561f7b196344b704ccd718f0a284f3e28
DIST zsh-completions-0.15.0.tar.gz 217047 SHA256 358c576a44247959966d65f673d2861f232dbef04457954d9ac06e1f5315ca51 SHA512 d4670eb960bf620d627e57ec8dfd92bfba004ccffbbbc3f5e1209fe1569f99477cdd7105837fc6052c7b017c8d0216a44505f60c69abf00031927e6f457c931d WHIRLPOOL b0ceed917498dd3ef843fcca73b6fc730055df3996e0dd19317c0591817662e9b4cf7a69d87dacddf3efd5e484e2d807b65bb4beec84fadc57b5f1b2864fc54c
+DIST zsh-completions-0.16.0.tar.gz 218282 SHA256 37fec2bfa7497165530b6afe6d6b837cefff3c8f918c36556cc5ef89f2781102 SHA512 f438dd42fed5cb6b18bc0de3d68792d0fcc6364ff7fc286a9359976987a812010d0c0ce7845d8794a87f1106968cb1afd72cbf73628d7128c1f6e76497f25108 WHIRLPOOL 3724acd47502de7a940c93d9d48d5bef1832c99ac9169a5b77fd2596d187c0d0f52e43e4bd6e88bd95b861cf022bfcb3c4e3920d26ab333b9177ff76d5016c6c
diff --git a/app-shells/zsh-completions/zsh-completions-0.16.0.ebuild b/app-shells/zsh-completions/zsh-completions-0.16.0.ebuild
new file mode 100644
index 000000000000..e5b1d5f40bc0
--- /dev/null
+++ b/app-shells/zsh-completions/zsh-completions-0.16.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/zsh-users/zsh-completions.git"
+else
+ SRC_URI="https://github.com/zsh-users/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Additional completion definitions for Zsh"
+HOMEPAGE="https://github.com/zsh-users/zsh-completions"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="app-shells/zsh"
+
+src_install() {
+ insinto /usr/share/zsh/site-functions
+ doins src/_*
+}
+
+pkg_postinst() {
+ elog
+ elog "If you happen to compile your functions, you may need to delete"
+ elog "~/.zcompdump{,.zwc} and recompile to make the new completions available"
+ elog "to your shell."
+ elog
+}