summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2019-05-27 22:45:55 -0400
committerMike Gilbert <floppym@gentoo.org>2019-05-28 00:01:28 -0400
commit90fd7eb38db6b71a1c8f8d0ce98ee71563cc41f5 (patch)
treeb8f0f45463b34178809aa62e3cc8dc1c819739ab /app-shells
parentdev-util/gn: bump to 0.1583 (diff)
downloadgentoo-90fd7eb38db6b71a1c8f8d0ce98ee71563cc41f5.tar.gz
gentoo-90fd7eb38db6b71a1c8f8d0ce98ee71563cc41f5.tar.bz2
gentoo-90fd7eb38db6b71a1c8f8d0ce98ee71563cc41f5.zip
app-shells/ksh: backport fix for gcc 9
Closes: https://bugs.gentoo.org/686560 Package-Manager: Portage-2.3.66_p2, Repoman-2.3.12_p111 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/ksh/Manifest2
-rw-r--r--app-shells/ksh/ksh-2020.0.0_alpha1.ebuild9
2 files changed, 10 insertions, 1 deletions
diff --git a/app-shells/ksh/Manifest b/app-shells/ksh/Manifest
index 175a6d279d84..01a1b8024282 100644
--- a/app-shells/ksh/Manifest
+++ b/app-shells/ksh/Manifest
@@ -1 +1,3 @@
DIST ksh-2020.0.0-alpha1.tar.gz 2041308 BLAKE2B 542f7936b7042485c0279c9b79f2d61f9580f0ae654abf60a8044254ed5fe228fa14d48dc7dd835201c32a9448182ca4cb702aac894a74bf5f92a4b866d1de70 SHA512 56c805bebe963dee7c27ba0357e26957fd8439f42c26f290ab32488ddde99f4b824e403c5dc097194eaf600e7379a010b1be4bf1e70bee76402e84909b38d981
+DIST ksh-conftab.patch 118773 BLAKE2B 63466e18a77cb86af80d6f6b4af74e3ac1edbfa735decfcd772633808a4593f6d4b057a99547482d17b22445e68c6d3e2becdf68516f913c73550da718f2abc3 SHA512 b29a70e8e31a259ac5bf556ddcdb5d4742a8dac4d11c06e4b5fc3043012e08b26d136cce8c18e9e8a1fe751044699d2258388d618408b09379732bea89a51765
+DIST ksh-solaris.patch 12317 BLAKE2B 90681bde2f3bad0e097a9367ea5a3f1d4c95f70c6e0c872dad769609f97a6332328e21399a3b9ba20f3840b3387a02370831ae4663457728bd8e41b7471c675b SHA512 5a0b818f44a860210e2a7795335d0edec01c61dd5ad04670bb2ca505690ff1b111dbda12d0d15e8b264113d4e7a5a42a49f64c9aba0cff809c2ce3185921acad
diff --git a/app-shells/ksh/ksh-2020.0.0_alpha1.ebuild b/app-shells/ksh/ksh-2020.0.0_alpha1.ebuild
index 4927a8e7fe18..b8f743ad437e 100644
--- a/app-shells/ksh/ksh-2020.0.0_alpha1.ebuild
+++ b/app-shells/ksh/ksh-2020.0.0_alpha1.ebuild
@@ -10,7 +10,9 @@ HOMEPAGE="https://github.com/att/ast"
MY_PV="${PV/_/-}"
MY_P="${PN}-${MY_PV}"
-SRC_URI="https://github.com/att/ast/releases/download/${MY_PV}/${MY_P}.tar.gz"
+SRC_URI="https://github.com/att/ast/releases/download/${MY_PV}/${MY_P}.tar.gz
+ https://github.com/att/ast/commit/db7fe39b744d071bb0428c91e2eb84877f068dac.patch -> ksh-solaris.patch
+ https://github.com/att/ast/commit/63e9edcb6084d4b164439065e2d71f3e900ec3c7.patch -> ksh-conftab.patch"
S="${WORKDIR}/${MY_P}"
LICENSE="CPL-1.0 EPL-1.0"
@@ -19,6 +21,11 @@ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
RDEPEND="!app-shells/pdksh"
+PATCHES=(
+ "${DISTDIR}"/ksh-solaris.patch
+ "${DISTDIR}"/ksh-conftab.patch
+)
+
src_install() {
meson_src_install
dodir /bin