summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-10-18 15:58:56 +0200
committerPacho Ramos <pacho@gentoo.org>2015-10-18 15:58:56 +0200
commit9ebfcb2ee3f7ae28562c8ca73104ee70e5644a98 (patch)
tree38d131e2e2c7e3b04deee1f4d8d1ce0d3ca4ab65 /app-shells
parentsys-kernel/openvz-sources: amd64/x86 stable wrt bug #562526 (diff)
downloadgentoo-9ebfcb2ee3f7ae28562c8ca73104ee70e5644a98.tar.gz
gentoo-9ebfcb2ee3f7ae28562c8ca73104ee70e5644a98.tar.bz2
gentoo-9ebfcb2ee3f7ae28562c8ca73104ee70e5644a98.zip
Revert "app-shells/pdmenu: Clean up old."
This reverts commit 02b747c5e5abf923e7ae803f73f39f3f1db73b06.
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/pdmenu/Manifest1
-rw-r--r--app-shells/pdmenu/files/pdmenu-impl-dec.patch16
-rw-r--r--app-shells/pdmenu/pdmenu-1.3.2-r1.ebuild58
3 files changed, 75 insertions, 0 deletions
diff --git a/app-shells/pdmenu/Manifest b/app-shells/pdmenu/Manifest
index cbcfa08d1a27..27b5f3a34502 100644
--- a/app-shells/pdmenu/Manifest
+++ b/app-shells/pdmenu/Manifest
@@ -1 +1,2 @@
+DIST pdmenu_1.3.2.tar.gz 160083 SHA256 7a7b68d50851a4f0f42467d9c5ee74bdb42591e35687f97ad3d2c915f9607d90 SHA512 9359dcf0d058349b502f0c39509d3c51658d80062f2c65c52010255ba97ffd1a3e5bf5cf4d6feffff6865ff1a26440a7523a447e9e4a2a0760cafc6a3109e945 WHIRLPOOL f92187058f4d057149c26c26b2ddb1c215c63690e4412d167b82da0ba77c81df81c9f0cdcc171eec9a4029ba188db38592dcc5ade53fefd9fc084febb7533ed6
DIST pdmenu_1.3.4.tar.gz 161002 SHA256 302aa81b8868133ff5a0f3e3e897f71d425bc628c0d7439addb623f12c277bea SHA512 2540b3040a799f4682de1014f8da750501000cef7080ea24b066a7e44971e33452a25e3885849bc47a156727641c4acb8d1268d3c16a2aab2cb37d510f50f3ad WHIRLPOOL ab5a0566b470d8db84b1da6308961b696d7a9490d8f30471c731d1537bbe0132a2d9c3a610ead61f55e5c8656c1d0021f5de40a4ae526a69895104dab48e0c86
diff --git a/app-shells/pdmenu/files/pdmenu-impl-dec.patch b/app-shells/pdmenu/files/pdmenu-impl-dec.patch
new file mode 100644
index 000000000000..c0cd7ce3ac99
--- /dev/null
+++ b/app-shells/pdmenu/files/pdmenu-impl-dec.patch
@@ -0,0 +1,16 @@
+ src/actions.c | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+diff --git a/src/actions.c b/src/actions.c
+index d42a63a..1f5a0d1 100644
+--- a/src/actions.c
++++ b/src/actions.c
+@@ -30,6 +30,8 @@
+ #include <libintl.h>
+ #define _(String) gettext (String)
+
++#include <ctype.h>
++
+ /* Handle a control c by either exiting pdmenu or doing nothing. */
+ void Handle_Ctrl_C() {
+ if (Q_Exits) {
diff --git a/app-shells/pdmenu/pdmenu-1.3.2-r1.ebuild b/app-shells/pdmenu/pdmenu-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..11b22e7db245
--- /dev/null
+++ b/app-shells/pdmenu/pdmenu-1.3.2-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="A simple console menu program"
+HOMEPAGE="http://joeyh.name/code/pdmenu/"
+SRC_URI="mirror://debian/pool/main/p/pdmenu/pdmenu_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~mips x86"
+IUSE="nls gpm examples"
+
+DEPEND="
+ sys-libs/slang
+ gpm? ( sys-libs/gpm )
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${PN}
+
+RESTRICT="test"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-impl-dec.patch
+ sed \
+ -e 's:\(-o pdmenu\):$(LDFLAGS) \1:g' \
+ -i Makefile || die
+}
+
+src_configure() {
+ econf \
+ $(use_with gpm) \
+ $(use_enable nls)
+}
+
+src_install() {
+ dobin pdmenu
+
+ dodoc doc/ANNOUNCE doc/BUGS doc/TODO
+
+ use examples && dodoc -r examples
+
+ mv doc/pdmenu.man doc/pdmenu.1
+ mv doc/pdmenurc.man doc/pdmenurc.5
+ doman doc/pdmenu.1 doc/pdmenurc.5
+
+}
+
+pkg_postinst() {
+ ewarn "Note this part from man page: Security warning! Any exec command"
+ ewarn "that uses the 'edit' flag will be a security hole. The user need"
+ ewarn "only to enter text with a ';' in it, and they can run an"
+ ewarn "arbitrary command after the semicolon!"
+}