summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2017-10-04 09:40:53 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2017-10-04 09:40:53 -0700
commite708bb0272bc7d7dce11e900f50615e9f85a902a (patch)
treee6e7d91edf72eff3a6a95618784494cf9c2e22e9 /app-shells
parentapp-shells/push: bump. (diff)
downloadgentoo-e708bb0272bc7d7dce11e900f50615e9f85a902a.tar.gz
gentoo-e708bb0272bc7d7dce11e900f50615e9f85a902a.tar.bz2
gentoo-e708bb0272bc7d7dce11e900f50615e9f85a902a.zip
app-shells/quoter: bump.
Closes: https://bugs.gentoo.org/628390 Package-Manager: Portage-2.3.8, Repoman-2.3.3 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/quoter/Manifest1
-rw-r--r--app-shells/quoter/quoter-4.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/app-shells/quoter/Manifest b/app-shells/quoter/Manifest
index ed44ac71c636..b94ab2c87ed5 100644
--- a/app-shells/quoter/Manifest
+++ b/app-shells/quoter/Manifest
@@ -1 +1,2 @@
DIST quoter-3.0_p2.tar.gz 10691 SHA256 19a335095991c8fa0f637c81b7e8b9a262af67e230507af87f3c113228965732 SHA512 23d77105fa05d79a7d0bcaa3f6aead25b7cb3b6f459d2740314616da587e03cd3e6b0b1e8af8f79904309bbe76603db848d42996ed7ae5ef779e27184a434fb5 WHIRLPOOL 1c083d7dc9bc8e1e4719b6e4c03087f39d4324df3aa70011e84087c7de3145f932ca3ae9fc1057b17dbe9471592c5d32ac99dff63b7962fb3c7548b31aa2a225
+DIST quoter-4.0.tar.gz 10902 SHA256 0aa7c42bfbe66ca5d04c8b2d2b75f398bd96e2d224bb1fd5dd00b51a143d6498 SHA512 711b03763ed619ece0cd8ff4e0971a6f78846d5d9a927324d1162af017a639d0b1ef50271fa80a3cb2239d795af08e49e24873db3c35afad01c8ad91ad2508ea WHIRLPOOL 9095d4bbc8b3a2f82f05afc92dd98db0868c2d0b74a4d24483dfbdb2b81534338050044a938d7e9e47706e96168d12460a73b8c65668a9af996c68d497ba41eb
diff --git a/app-shells/quoter/quoter-4.0.ebuild b/app-shells/quoter/quoter-4.0.ebuild
new file mode 100644
index 000000000000..73d72d80c7a7
--- /dev/null
+++ b/app-shells/quoter/quoter-4.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2016-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs vcs-snapshot
+
+DESCRIPTION="Quote arguments or standard input for usage in POSIX shell by eval"
+HOMEPAGE="https://github.com/vaeth/quoter/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE=""
+
+src_compile() {
+ emake CC="$(tc-getCC)" EPREFIX="${EPREFIX}"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" EPREFIX="${EPREFIX}" install
+ dodoc README
+}