summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-12-07 03:17:52 -0500
committerMike Frysinger <vapier@gentoo.org>2016-12-07 03:17:52 -0500
commite8b779ed01be648a1094348d7b02ae7e0898a120 (patch)
tree39827afeda1220280caba059b3f53b40f99d23b8 /app-shells
parentapp-shells/bashdb: hardcode path to debugger main #591994 (diff)
downloadgentoo-e8b779ed01be648a1094348d7b02ae7e0898a120.tar.gz
gentoo-e8b779ed01be648a1094348d7b02ae7e0898a120.tar.bz2
gentoo-e8b779ed01be648a1094348d7b02ae7e0898a120.zip
app-shells/bashdb: version bump to 4.4.0.92
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bashdb/Manifest1
-rw-r--r--app-shells/bashdb/bashdb-4.4.0.92.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-shells/bashdb/Manifest b/app-shells/bashdb/Manifest
index ad7463f0e83b..5f1d596aadcd 100644
--- a/app-shells/bashdb/Manifest
+++ b/app-shells/bashdb/Manifest
@@ -1 +1,2 @@
DIST bashdb-4.3-0.91.tar.bz2 660370 SHA256 60117745813f29070a034c590c9d70153cc47f47024ae54bfecdc8cd86d9e3ea SHA512 903710e61efcf272213c3dcc20799842e8ef969e791e3d1a8eab071e5b7538a195f621320945019611042ed623d005e481bd75724194cc10cb6f668b615ce3af WHIRLPOOL 075ee878713a7611b7437d4c3420669c6bcff949a9e2991cbfc533874e2b215e1c9a4d23f4f414205d979190c09eec1a2a8daa3857053dfade6f8864211534be
+DIST bashdb-4.4-0.92.tar.bz2 678961 SHA256 6a8c2655e04339b954731a0cb0d9910e2878e45b2fc08fe469b93e4f2dbaaf92 SHA512 68d5cdf4fb6cbacb0e7b69fb793ab9ead3114e152ea87dfb9d540103c9975af8dcaa78ad9a89b00a0f85f3ab1f090d9b6ca6a13c3e09673b5ab073762500fb80 WHIRLPOOL 5577a7a9a3e905a758ffbed931846bc408c038ce80cfedd7e2bd6bb57902acb63567b0ed461fd4ee76ba6d0a8d4109d9ecfd651367d42f2a1e5ab5e5546bfb54
diff --git a/app-shells/bashdb/bashdb-4.4.0.92.ebuild b/app-shells/bashdb/bashdb-4.4.0.92.ebuild
new file mode 100644
index 000000000000..e48a511f0157
--- /dev/null
+++ b/app-shells/bashdb/bashdb-4.4.0.92.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+MY_P="${PN}-${PV:0:3}-${PV:4}"
+DESCRIPTION="bash source code debugging"
+HOMEPAGE="http://bashdb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bashdb/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="!>=app-shells/bash-${PV:0:1}.$((${PV:2:1}+1))"
+
+S="${WORKDIR}/${MY_P}"
+
+# Unfortunately, not all tests pass. #276877
+RESTRICT="test"
+
+src_prepare() {
+ default
+
+ # We don't install this, so don't bother building it. #468044
+ sed -i 's:texi2html:true:' doc/Makefile.in || die
+}
+
+src_configure() {
+ # This path matches the bash sources. If we ever change bash,
+ # we'll probably have to change this to match. #591994
+ econf --with-dbg-main='$(PKGDATADIR)/bashdb-main.inc'
+}