summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-03-08 21:53:18 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-03-08 21:53:57 +0100
commitfb571d9b5e37dd1b6594fdea8f15559d228b9125 (patch)
treedb33e8a06acd35f4b5cc0ee95565095438a0dccb /app-shells
parentprofiles/arm64: remove qt5 from use.mask (diff)
downloadgentoo-fb571d9b5e37dd1b6594fdea8f15559d228b9125.tar.gz
gentoo-fb571d9b5e37dd1b6594fdea8f15559d228b9125.tar.bz2
gentoo-fb571d9b5e37dd1b6594fdea8f15559d228b9125.zip
app-shells/zsh-completions: Version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/zsh-completions/Manifest1
-rw-r--r--app-shells/zsh-completions/zsh-completions-0.17.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-shells/zsh-completions/Manifest b/app-shells/zsh-completions/Manifest
index 4b3c000f7e97..e592d7a66f72 100644
--- a/app-shells/zsh-completions/Manifest
+++ b/app-shells/zsh-completions/Manifest
@@ -1,2 +1,3 @@
DIST zsh-completions-0.15.0.tar.gz 217047 SHA256 358c576a44247959966d65f673d2861f232dbef04457954d9ac06e1f5315ca51 SHA512 d4670eb960bf620d627e57ec8dfd92bfba004ccffbbbc3f5e1209fe1569f99477cdd7105837fc6052c7b017c8d0216a44505f60c69abf00031927e6f457c931d WHIRLPOOL b0ceed917498dd3ef843fcca73b6fc730055df3996e0dd19317c0591817662e9b4cf7a69d87dacddf3efd5e484e2d807b65bb4beec84fadc57b5f1b2864fc54c
DIST zsh-completions-0.16.0.tar.gz 218282 SHA256 37fec2bfa7497165530b6afe6d6b837cefff3c8f918c36556cc5ef89f2781102 SHA512 f438dd42fed5cb6b18bc0de3d68792d0fcc6364ff7fc286a9359976987a812010d0c0ce7845d8794a87f1106968cb1afd72cbf73628d7128c1f6e76497f25108 WHIRLPOOL 3724acd47502de7a940c93d9d48d5bef1832c99ac9169a5b77fd2596d187c0d0f52e43e4bd6e88bd95b861cf022bfcb3c4e3920d26ab333b9177ff76d5016c6c
+DIST zsh-completions-0.17.0.tar.gz 221135 SHA256 e1797e22e2bbbe50bf61f88db43216c0aef53713c84373bafddf6090b1fe8f68 SHA512 1c14d8842fd1b09588ab177ae1b85ef5ce698f753ca1e606521477476801c135d8463a6fff2eff2ae26410b7c3db0ac27f1c43aea07668cba007a3e762143ee7 WHIRLPOOL 7010ad5defec40fecd044b1890bf61682964883cb35aba803f038c4cfd271d20cb30021f7679dbdf104de38811ca3223c4c5ed56dad918e1066d142c833b7dfc
diff --git a/app-shells/zsh-completions/zsh-completions-0.17.0.ebuild b/app-shells/zsh-completions/zsh-completions-0.17.0.ebuild
new file mode 100644
index 000000000000..e5b1d5f40bc0
--- /dev/null
+++ b/app-shells/zsh-completions/zsh-completions-0.17.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/zsh-users/zsh-completions.git"
+else
+ SRC_URI="https://github.com/zsh-users/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Additional completion definitions for Zsh"
+HOMEPAGE="https://github.com/zsh-users/zsh-completions"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="app-shells/zsh"
+
+src_install() {
+ insinto /usr/share/zsh/site-functions
+ doins src/_*
+}
+
+pkg_postinst() {
+ elog
+ elog "If you happen to compile your functions, you may need to delete"
+ elog "~/.zcompdump{,.zwc} and recompile to make the new completions available"
+ elog "to your shell."
+ elog
+}