summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/7plus
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/7plus')
-rw-r--r--app-text/7plus/7plus-2.25.ebuild36
-rw-r--r--app-text/7plus/Manifest1
-rw-r--r--app-text/7plus/metadata.xml7
3 files changed, 44 insertions, 0 deletions
diff --git a/app-text/7plus/7plus-2.25.ebuild b/app-text/7plus/7plus-2.25.ebuild
new file mode 100644
index 000000000000..a40c26a36ea2
--- /dev/null
+++ b/app-text/7plus/7plus-2.25.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+S="${WORKDIR}/7plsrc.${PV//./}"
+DESCRIPTION="An encoder for packet radio"
+HOMEPAGE="http://home.t-online.de/home/dg1bbq/7plus.htm"
+SRC_URI="http://home.t-online.de/home/dg1bbq/7pl${PV//./}sr.tgz"
+
+LICENSE="7plus"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="sys-apps/sed"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -e "s:CC = gcc:CC = $(tc-getCC):" \
+ -e "s:= -O2:+=:" \
+ -e "s:LDFLAGS = -s:LDFLAGS +=:" linux.mak > Makefile \
+ || die "sed Makefile failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin 7plus || die "dobin failed"
+ dodoc 7pl_hist.nts 7plh_old.nts format.def
+}
diff --git a/app-text/7plus/Manifest b/app-text/7plus/Manifest
new file mode 100644
index 000000000000..a719a5506a62
--- /dev/null
+++ b/app-text/7plus/Manifest
@@ -0,0 +1 @@
+DIST 7pl225sr.tgz 65122 SHA256 2d1f8fdd6e514d7e3fdae55a670555d5d30b31c6b14c59ae7af218af7f923e10 SHA512 c1c303b19ed14b3398a8a0c58eb505f03f27e957cfe3cbf2432db115a1efaf6a637e657490079791d245aebf6d2b14497e111b5d5cfd52637f25f135e5008476 WHIRLPOOL 769a758305a67bbfee56b7b2125725b4a5031d4a8d5047d635b45bd414899a28900b707d9b2a04c198511e4676e122e7b30b547d413b2c92eca9bd33fc6eefa7
diff --git a/app-text/7plus/metadata.xml b/app-text/7plus/metadata.xml
new file mode 100644
index 000000000000..d9cd2cad66c2
--- /dev/null
+++ b/app-text/7plus/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>