summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-01-30 11:12:38 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-01-30 11:22:02 +0100
commit3a54649a007a5a66729b9add9f5d80a4d89dba54 (patch)
tree43e4aec61fa534f98eb258891635cd2c1bb6f0fa /app-text/aspell
parentprofiles: mask app-text/tesseract alpha release (diff)
downloadgentoo-3a54649a007a5a66729b9add9f5d80a4d89dba54.tar.gz
gentoo-3a54649a007a5a66729b9add9f5d80a4d89dba54.tar.bz2
gentoo-3a54649a007a5a66729b9add9f5d80a4d89dba54.zip
app-text/aspell: Bump to version 0.60.7_rc1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-text/aspell')
-rw-r--r--app-text/aspell/Manifest1
-rw-r--r--app-text/aspell/aspell-0.60.7_rc1.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/app-text/aspell/Manifest b/app-text/aspell/Manifest
index c9946b7a6125..a41b6364480c 100644
--- a/app-text/aspell/Manifest
+++ b/app-text/aspell/Manifest
@@ -1 +1,2 @@
DIST aspell-0.60.6.1.tar.gz 1878163 SHA256 f52583a83a63633701c5f71db3dc40aab87b7f76b29723aeb27941eff42df6e1 SHA512 f310c7590be98406589b5c26ca36a2ecfe4733f0b40fd6c176b96b7955ef2b5cd0ec9a3d770cf132146ae7a896042b4b698945112995ee1ae66adcfa5542247f WHIRLPOOL 0c77b95a29b598491c12cf22737d5ff758b2758b4f815356d2f52da398afe2b45209cd3b59f90e5b3c1976ee8a09e8cd553507bd93a0cd49043c8531f9a4990b
+DIST aspell-0.60.7-rc1.tar.gz 2034916 SHA256 86b5662f24316142f70c5890787bdc5596625ca3604dfe85926ee61f27f2365e SHA512 e13240d78b8afd74d8a8cfd5fc7fe2081de85b33621e86543cdf942ed601d36c4e0cbf38a54be083e951127fa9435677cec2997387cb0e7b51a5597386e7e8d1 WHIRLPOOL 6c48decc0470827024584e0519de70a9b6ffbe1526617eb86614123161dfabcaad7ded9e3d73698ade427523370f7f52f46570bb8052c6502ed30ee4ce2a5799
diff --git a/app-text/aspell/aspell-0.60.7_rc1.ebuild b/app-text/aspell/aspell-0.60.7_rc1.ebuild
new file mode 100644
index 000000000000..7e81cedc07cc
--- /dev/null
+++ b/app-text/aspell/aspell-0.60.7_rc1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools flag-o-matic libtool toolchain-funcs
+
+MY_P="${P/_/-}"
+
+DESCRIPTION="A spell checker replacement for ispell"
+HOMEPAGE="http://aspell.net/"
+if [[ "${PV}" = *_rc* ]] ; then
+ SRC_URI="mirror://gnu-alpha/aspell/${MY_P}.tar.gz"
+else
+ SRC_URI="mirror://gnu/aspell/${MY_P}.tar.gz"
+fi
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="nls unicode"
+
+PDEPEND="app-dicts/aspell-en"
+LANGS="af be bg br ca cs cy da de de@1901 el en eo es et fi fo fr ga gl he hr
+hu hy is it la lt nl no pl pt pt-BR ro ru sk sl sr sv uk vi"
+for lang in ${LANGS}; do
+ IUSE+=" l10n_${lang/@/-}"
+ # Need to keep linguas_* for now, since aspell uses gettext
+ IUSE+=" linguas_${lang/-/_}"
+ case ${lang} in
+ de@1901) dict="de-alt" ;;
+ pt-BR) dict="pt-br" ;;
+ *) dict="${lang}" ;;
+ esac
+ PDEPEND+=" l10n_${lang/@/-}? ( app-dicts/aspell-${dict} )"
+done
+unset dict lang LANGS
+
+# English dictionary 0.5 is incompatible with aspell-0.6
+RDEPEND="
+ sys-libs/ncurses:0=[unicode?]
+ nls? ( virtual/libintl )
+ !=app-dicts/aspell-en-0.5*
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+HTML_DOCS=( manual/aspell{,-dev}.html )
+PATCHES=(
+ "${FILESDIR}/${PN}-0.60.5-nls.patch"
+ "${FILESDIR}/${PN}-0.60.5-solaris.patch"
+ "${FILESDIR}/${PN}-0.60.6-darwin-bundles.patch"
+ "${FILESDIR}/${PN}-0.60.6.1-clang.patch"
+ # includes fix for bug #467602
+ "${FILESDIR}/${PN}-0.60.6.1-unicode.patch"
+)
+
+src_prepare() {
+ default
+
+ rm m4/lt* m4/libtool.m4 || die
+ eautoreconf
+ elibtoolize --reverse-deps
+
+ # Parallel install of libtool libraries doesn't always work.
+ # https://lists.gnu.org/archive/html/libtool/2011-03/msg00003.html
+ # This has to be after automake has run so that we don't clobber
+ # the default target that automake creates for us.
+ echo 'install-filterLTLIBRARIES: install-libLTLIBRARIES' >> Makefile.in || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable unicode) \
+ --disable-static \
+ --sysconfdir="${EPREFIX}"/etc/aspell
+}
+
+src_install() {
+ default
+
+ docinto examples
+ dodoc "${S}"/examples/*.c
+
+ # install ispell/aspell compatibility scripts
+ newbin scripts/ispell ispell-aspell
+ newbin scripts/spell spell-aspell
+
+ # we explicitly pass '--disable-static' to econf,
+ # hence we can delete .la files unconditionally
+ find "${D}" -name '*.la' -delete || die
+}