summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2015-08-18 15:06:11 +0200
committerJulian Ospald <hasufell@gentoo.org>2015-08-18 15:06:26 +0200
commitbf9a47c780ae3dd3d9b409198f1d9679e447507c (patch)
treea778cd36ae9ca395c8ac1cd03005cd9d319935ce /app-text/aspell
parentsys-libs/glibc: fix from upstrea for hppa/pie #505312 (diff)
downloadgentoo-bf9a47c780ae3dd3d9b409198f1d9679e447507c.tar.gz
gentoo-bf9a47c780ae3dd3d9b409198f1d9679e447507c.tar.bz2
gentoo-bf9a47c780ae3dd3d9b409198f1d9679e447507c.zip
app-text/aspell: fix compilation with clang
Gentoo-Bug: 526804 Reported-by: Markus Ullmann
Diffstat (limited to 'app-text/aspell')
-rw-r--r--app-text/aspell/aspell-0.60.6.1-r2.ebuild3
-rw-r--r--app-text/aspell/files/aspell-0.60.6.1-clang.patch47
2 files changed, 49 insertions, 1 deletions
diff --git a/app-text/aspell/aspell-0.60.6.1-r2.ebuild b/app-text/aspell/aspell-0.60.6.1-r2.ebuild
index fb5fd3ebdf9a..d24a04c98413 100644
--- a/app-text/aspell/aspell-0.60.6.1-r2.ebuild
+++ b/app-text/aspell/aspell-0.60.6.1-r2.ebuild
@@ -57,7 +57,8 @@ src_prepare() {
epatch \
"${FILESDIR}/${PN}-0.60.5-nls.patch" \
"${FILESDIR}/${PN}-0.60.5-solaris.patch" \
- "${FILESDIR}/${PN}-0.60.6-darwin-bundles.patch"
+ "${FILESDIR}/${PN}-0.60.6-darwin-bundles.patch" \
+ "${FILESDIR}/${PN}-0.60.6.1-clang.patch"
rm m4/lt* m4/libtool.m4
eautoreconf
diff --git a/app-text/aspell/files/aspell-0.60.6.1-clang.patch b/app-text/aspell/files/aspell-0.60.6.1-clang.patch
new file mode 100644
index 000000000000..76cfaa868e31
--- /dev/null
+++ b/app-text/aspell/files/aspell-0.60.6.1-clang.patch
@@ -0,0 +1,47 @@
+From https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=180565
+--- interfaces/cc/aspell.h.orig 2011-07-02 17:53:27.000000000 -0400
++++ interfaces/cc/aspell.h 2015-07-29 11:23:32.000000000 -0400
+@@ -237,6 +237,7 @@
+ /******************************** errors ********************************/
+
+
++#ifndef ASPELL_ERRORS__HPP
+ extern const struct AspellErrorInfo * const aerror_other;
+ extern const struct AspellErrorInfo * const aerror_operation_not_supported;
+ extern const struct AspellErrorInfo * const aerror_cant_copy;
+@@ -322,6 +323,7 @@
+ extern const struct AspellErrorInfo * const aerror_bad_magic;
+ extern const struct AspellErrorInfo * const aerror_expression;
+ extern const struct AspellErrorInfo * const aerror_invalid_expression;
++#endif
+
+
+ /******************************* speller *******************************/
+--- prog/aspell.cpp.orig 2011-07-04 05:13:58.000000000 -0400
++++ prog/aspell.cpp 2015-07-29 11:22:57.000000000 -0400
+@@ -25,6 +25,7 @@
+ # include <langinfo.h>
+ #endif
+
++#include "errors.hpp"
+ #include "aspell.h"
+
+ #ifdef USE_FILE_INO
+@@ -40,7 +41,6 @@
+ #include "convert.hpp"
+ #include "document_checker.hpp"
+ #include "enumeration.hpp"
+-#include "errors.hpp"
+ #include "file_util.hpp"
+ #include "fstream.hpp"
+ #include "info.hpp"
+--- prog/checker_string.hpp.orig 2011-07-02 17:09:09.000000000 -0400
++++ prog/checker_string.hpp 2015-07-29 11:24:50.000000000 -0400
+@@ -6,6 +6,7 @@
+
+ #include <stdio.h>
+
++#include "errors.hpp"
+ #include "aspell.h"
+
+ #include "vector.hpp"