summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/bibus/bibus-1.5.2-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/bibus/bibus-1.5.2-r1.ebuild')
-rw-r--r--app-text/bibus/bibus-1.5.2-r1.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/app-text/bibus/bibus-1.5.2-r1.ebuild b/app-text/bibus/bibus-1.5.2-r1.ebuild
new file mode 100644
index 000000000000..1cc6cc272cb7
--- /dev/null
+++ b/app-text/bibus/bibus-1.5.2-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit eutils fdo-mime multilib python-r1 versionator
+
+DESCRIPTION="Bibliographic and reference management software, integrates with L/OO.o and MS Word"
+HOMEPAGE="http://bibus-biblio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}-biblio/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE="mysql"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Most of this mess is designed to give the choice of sqlite or mysql
+# but prefer sqlite. We also need to default to sqlite if neither is requested.
+# Cannot depend on virtual/ooo
+# bibus fails to start with app-office/openoffice-bin (bug #288232).
+RDEPEND="
+ ${PYTHON_DEPS}
+ app-office/libreoffice
+ dev-python/wxpython:2.8[${PYTHON_USEDEP}]
+ dev-db/sqliteodbc
+ dev-db/unixODBC
+ mysql? (
+ dev-python/mysql-python[${PYTHON_USEDEP}]
+ dev-db/myodbc
+ )"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ if [[ -d "/usr/$(get_libdir)/openoffice" ]] ; then
+ OFFICESUITE="/usr/$(get_libdir)/openoffice"
+ else
+ OFFICESUITE="/usr/$(get_libdir)/libreoffice"
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-install.patch
+}
+
+src_compile() { :; }
+
+src_install() {
+ einfo "Installing for ${OFFICESUITE}"
+ installation() {
+ emake \
+ DESTDIR="${D}" \
+ prefix="${EPREFIX}/usr" \
+ oopath="${OFFICESUITE}/program" \
+ ooure="${OFFICESUITE}/ure-link/lib" \
+ oobasis="${OFFICESUITE}/program" \
+ sysconfdir="${EPREFIX}/etc" \
+ pythondir="$(python_get_sitedir)" \
+ python=${PYTHON} \
+ install install-doc-en
+ }
+ python_foreach_impl installation
+ python_parallel_foreach_impl python_optimize
+
+ python_parallel_foreach_impl python_newscript bibusStart.py ${PN}
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}