summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/bibutils/bibutils-4.12.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/bibutils/bibutils-4.12.ebuild')
-rw-r--r--app-text/bibutils/bibutils-4.12.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-text/bibutils/bibutils-4.12.ebuild b/app-text/bibutils/bibutils-4.12.ebuild
new file mode 100644
index 000000000000..2ab6fd8125ec
--- /dev/null
+++ b/app-text/bibutils/bibutils-4.12.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit toolchain-funcs
+
+MY_P="${PN}_${PV}"
+DESCRIPTION="Interconverts between various bibliography formats using a common XML intermediate"
+HOMEPAGE="http://www.scripps.edu/~cdputnam/software/bibutils/"
+SRC_URI="http://www.scripps.edu/~cdputnam/software/bibutils/${MY_P}_src.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # The custom configure script sucks, so we'll just do its
+ # job ourselves
+ rm -f Makefile configure || die "Failed to purge old Makefile"
+ sed \
+ -e "s:REPLACE_CC:CC=\"$(tc-getCC) ${CFLAGS}\":g" \
+ -e "s:REPLACE_RANLIB:RANLIB=\"$(tc-getRANLIB)\":g" \
+ -e "s:REPLACE_INSTALLDIR:\"${D}/usr/bin\":g" \
+ -e 's:REPLACE_POSTFIX::g' \
+ -e 's:make:$(MAKE):g' \
+ Makefile_start > Makefile \
+ || die "Failed to set up Makefile"
+}
+
+src_install() {
+ dodir /usr/bin
+ emake install || die
+ dodoc ChangeLog || die
+}