summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2019-01-11 22:23:11 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2019-01-11 22:23:38 +0100
commitd9c3adb551b63268fd4011bb1eb14a1018b49ea0 (patch)
treea1c45538f153c1b8e50f9e940534ce2e24e9d8d7 /app-text/bibutils
parentapp-text/xmlto: arm64 stable (bug #669068) (diff)
downloadgentoo-d9c3adb551b63268fd4011bb1eb14a1018b49ea0.tar.gz
gentoo-d9c3adb551b63268fd4011bb1eb14a1018b49ea0.tar.bz2
gentoo-d9c3adb551b63268fd4011bb1eb14a1018b49ea0.zip
app-text/bibutils: Version bump
Closes: https://bugs.gentoo.org/613346 Closes: https://bugs.gentoo.org/613352 Bug: https://bugs.gentoo.org/662884 Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'app-text/bibutils')
-rw-r--r--app-text/bibutils/Manifest1
-rw-r--r--app-text/bibutils/bibutils-6.7.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-text/bibutils/Manifest b/app-text/bibutils/Manifest
index d1c186c8d516..4d522560a791 100644
--- a/app-text/bibutils/Manifest
+++ b/app-text/bibutils/Manifest
@@ -1 +1,2 @@
DIST bibutils_4.12_src.tgz 447566 BLAKE2B 64d185963028f29f4efb64c63ee6ddb59961744d525d4dbaf28bdd1edb28ac8ea86529082995d11245c258895f27457c9d01594564a44caa837b0ba76052b969 SHA512 04329ecb685bf4d5314c6d3a2d5bb21e67112d73bcb49f5a7808a4082f32a9aecb40add4ec4b5320be35f49cd8e101dc1e35409e7c6cad8c39238d2122f91dd0
+DIST bibutils_6.7_src.tgz 580792 BLAKE2B 29c5863bc414ef7b2f362d95352c0e042c1bcc3275017df82b0206d96520b3f5c3fe1e12563577b84a8bd94b0677bf1ad04ecbd80dcbcc194a71037bbd6facba SHA512 08db07408eee26bce42dbd00b7e821ef41dc12c7ce847425e81145927bcfc6ea7180ff719056e089917811aa9675a09dd52e1e02b8187b8618f67647efcb1236
diff --git a/app-text/bibutils/bibutils-6.7.ebuild b/app-text/bibutils/bibutils-6.7.ebuild
new file mode 100644
index 000000000000..0b626bb59e52
--- /dev/null
+++ b/app-text/bibutils/bibutils-6.7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+MY_P="${PN}_${PV}"
+DESCRIPTION="Interconverts between various bibliography formats using common XML intermediate"
+HOMEPAGE="https://sourceforge.net/p/bibutils/home/Bibutils/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}_src.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ # The custom configure script still sucks several releases later, so we'll
+ # just do its job ourselves
+ rm -f Makefile configure || die "Failed to purge old Makefile"
+ sed \
+ -e "s:REPLACE_CC:$(tc-getCC):g" \
+ -e "s:REPLACE_EXEEXT::g" \
+ -e "s:REPLACE_LIBTARGET:libbibutils.so:g" \
+ -e "s:REPLACE_LIBEXT:.so:g" \
+ -e "s:REPLACE_CFLAGS:${CFLAGS}:g" \
+ -e "s:REPLACE_CLIBFLAGS:${CFLAGS} -fPIC:g" \
+ -e "s:REPLACE_RANLIB:$(tc-getRANLIB):g" \
+ -e 's:REPLACE_POSTFIX::g' \
+ -e "s:REPLACE_INSTALLDIR:\"${D}/usr/bin\":g" \
+ -e "s:REPLACE_LIBINSTALLDIR:\"${D}/usr/$(get_libdir)\":g" \
+ -e 's:make:$(MAKE):g' \
+ Makefile_start > Makefile \
+ || die "Failed to set up Makefile"
+
+ cp lib/Makefile.dynamic lib/Makefile || die
+ cp bin/Makefile.dynamic bin/Makefile || die
+ cp test/Makefile.dynamic test/Makefile || die
+}
+
+src_install() {
+ dodir /usr/bin
+ emake install
+ dodoc ChangeLog
+}