summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/chasen/chasen-2.4.4-r3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/chasen/chasen-2.4.4-r3.ebuild')
-rw-r--r--app-text/chasen/chasen-2.4.4-r3.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/app-text/chasen/chasen-2.4.4-r3.ebuild b/app-text/chasen/chasen-2.4.4-r3.ebuild
new file mode 100644
index 000000000000..3292f52b5b7e
--- /dev/null
+++ b/app-text/chasen/chasen-2.4.4-r3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+inherit perl-module
+
+DESCRIPTION="Japanese Morphological Analysis System, ChaSen"
+HOMEPAGE="http://chasen-legacy.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp//chasen-legacy/32224/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 x86 ~sparc-solaris"
+IUSE="perl static-libs"
+
+DEPEND=">=dev-libs/darts-0.32"
+RDEPEND="${DEPEND}
+ perl? ( !dev-perl/Text-ChaSen )"
+PDEPEND=">=app-dicts/ipadic-2.7.0"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-cve-2011-4000.patch
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+ if use perl ; then
+ cd "${S}"/perl
+ perl-module_src_configure
+ fi
+}
+
+src_compile() {
+ emake || die
+ if use perl ; then
+ cd "${S}"/perl
+ perl-module_src_compile
+ fi
+}
+
+src_test() {
+ emake check || die
+ if use perl ; then
+ cd "${S}"/perl
+ perl-module_src_test
+ fi
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+
+ if use perl ; then
+ cd "${S}"/perl
+ perl-module_src_install
+ newdoc README README.perl
+ fi
+
+ if ! use static-libs ; then
+ find "${ED}" -name '*.la' -delete
+ fi
+}