summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/cpdf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/cpdf')
-rw-r--r--app-text/cpdf/Manifest1
-rw-r--r--app-text/cpdf/cpdf-2.1.1-r1.ebuild42
-rw-r--r--app-text/cpdf/metadata.xml11
3 files changed, 54 insertions, 0 deletions
diff --git a/app-text/cpdf/Manifest b/app-text/cpdf/Manifest
new file mode 100644
index 000000000000..1352d0ae2f84
--- /dev/null
+++ b/app-text/cpdf/Manifest
@@ -0,0 +1 @@
+DIST cpdf-2.1.1.tar.gz 349536 SHA256 00a3c8b6f1ff60feff7d0b72c095befb576c08edc35ffee28a4d3a24ad599956 SHA512 aa06efaf098d3fe3f560ea30da9c3546e13d294b22d61c4cc3df553eb90e338d59ee1b51d14d7982ce52967bcf98c2afec9a5b5ae101e2183961f4be862c6517 WHIRLPOOL 317af6b976820ddbf3340b75e026f673bd47a7ce4f7de715cd6d71754b1fd403a4fadddffee85023dfd9a6aa44dfeeaf8dfb025784e70d0c33f0418420b80fc3
diff --git a/app-text/cpdf/cpdf-2.1.1-r1.ebuild b/app-text/cpdf/cpdf-2.1.1-r1.ebuild
new file mode 100644
index 000000000000..473f15fa3281
--- /dev/null
+++ b/app-text/cpdf/cpdf-2.1.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="A command line tool for manipulating PDF files"
+HOMEPAGE="http://community.coherentpdf.com/ https://github.com/johnwhitington/cpdf-source/"
+SRC_URI="https://github.com/johnwhitington/cpdf-source/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# BSD is only for xmlm.ml
+LICENSE="Coherent-Graphics BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-lang/ocaml-4:=
+ dev-ml/camlpdf:="
+DEPEND="${RDEPEND}"
+
+RESTRICT="mirror bindist"
+
+S=${WORKDIR}/${PN}-source-${PV}
+
+src_compile() {
+ # parallel make issues
+ emake -j1
+}
+
+src_install() {
+ findlib_src_install
+
+ dobin cpdf
+ dodoc Changes README.md
+
+ if use doc ; then
+ dodoc cpdfmanual.pdf
+ dohtml doc/cpdf/html/*
+ fi
+}
diff --git a/app-text/cpdf/metadata.xml b/app-text/cpdf/metadata.xml
new file mode 100644
index 000000000000..9202b41eeac7
--- /dev/null
+++ b/app-text/cpdf/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">johnwhitington/cpdf-source</remote-id>
+ </upstream>
+</pkgmetadata>