summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2017-12-17 18:11:14 +0900
committerAkinori Hattori <hattya@gentoo.org>2017-12-17 18:18:36 +0900
commit5bc0a49e4ab1c77952274f0af64ce163c814c272 (patch)
tree27c583f8ebec7b55fc2dcbb715494ffb264dbf4c /app-text/crf++
parentapp-text/crf++: update HOMEPAGE and SRC_URI (diff)
downloadgentoo-5bc0a49e4ab1c77952274f0af64ce163c814c272.tar.gz
gentoo-5bc0a49e4ab1c77952274f0af64ce163c814c272.tar.bz2
gentoo-5bc0a49e4ab1c77952274f0af64ce163c814c272.zip
app-text/crf++: update to EAPI 6
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'app-text/crf++')
-rw-r--r--app-text/crf++/crf++-0.54.ebuild53
-rw-r--r--app-text/crf++/crf++-0.58.ebuild46
2 files changed, 54 insertions, 45 deletions
diff --git a/app-text/crf++/crf++-0.54.ebuild b/app-text/crf++/crf++-0.54.ebuild
index 40689e9a48f1..cd0706716eb3 100644
--- a/app-text/crf++/crf++-0.54.ebuild
+++ b/app-text/crf++/crf++-0.54.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="3"
-inherit autotools eutils
+EAPI="6"
+
+inherit autotools
+
+MY_P="${P^^[crf]}"
-MY_P="${P/crf/CRF}"
DESCRIPTION="Yet Another CRF toolkit for segmenting/labelling sequential data"
HOMEPAGE="https://taku910.github.io/crfpp/"
SRC_URI="mirror://sourceforge/crfpp/${MY_P}.tar.gz"
@@ -16,45 +18,48 @@ IUSE="examples static-libs"
S="${WORKDIR}/${MY_P}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-automake-1.13.patch
+ "${FILESDIR}"/${P}-c++11.patch
+ "${FILESDIR}"/${P}-gcc46.patch
+)
+HTML_DOCS=( doc/. )
+
src_prepare() {
sed -i \
-e "/CFLAGS/s/-O3/${CFLAGS}/" \
-e "/CXXFLAGS/s/-O3/${CXXFLAGS}/" \
- configure.in || die
-
- epatch "${FILESDIR}"/${PN}-automake-1.13.patch
- epatch "${FILESDIR}"/${P}-c++11.patch
- # bug #365921
- epatch "${FILESDIR}/${P}-gcc46.patch"
+ configure.in
+ default
+ mv configure.{in,ac} || die
eautoreconf
}
src_configure() {
- econf $(use_enable static-libs static) || die
+ econf $(use_enable static-libs static)
}
src_test() {
- for task in example/* ; do
- (
- cd "${task}"
- ./exec.sh || die "failed test in ${task}"
- )
+ local d
+ for d in example/*; do
+ cd "${d}"
+ ./exec.sh || die "failed test in ${d}"
+ cd - >/dev/null
done
}
src_install() {
- emake DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" install
+ einstalldocs
- if ! use static-libs ; then
- find "${ED}" -name "*.la" -type f -delete || die
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/example
+ insinto /usr/share/doc/${PF}
+ doins -r example
fi
- dodoc AUTHORS README || die
- dohtml -r doc/* || die
-
- if use examples ; then
- insinto /usr/share/doc/${PF}
- doins -r example || die
+ if ! use static-libs; then
+ find "${ED}" -name "*.la" -type f -delete || die
fi
}
diff --git a/app-text/crf++/crf++-0.58.ebuild b/app-text/crf++/crf++-0.58.ebuild
index 9f0bb22fa51e..09adecd384f6 100644
--- a/app-text/crf++/crf++-0.58.ebuild
+++ b/app-text/crf++/crf++-0.58.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="3"
-inherit autotools eutils
+EAPI="6"
+
+inherit autotools
+
+MY_P="${P^^[crf]}"
-MY_P="${P/crf/CRF}"
DESCRIPTION="Yet Another CRF toolkit for segmenting/labelling sequential data"
HOMEPAGE="https://taku910.github.io/crfpp/"
SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
@@ -16,42 +18,44 @@ IUSE="examples static-libs"
S="${WORKDIR}/${MY_P}"
+PATCHES=( "${FILESDIR}"/${PN}-automake-1.13.patch )
+HTML_DOCS=( doc/. )
+
src_prepare() {
sed -i \
-e "/CFLAGS/s/-O3/${CFLAGS}/" \
-e "/CXXFLAGS/s/-O3/${CXXFLAGS}/" \
- configure.in || die
-
- epatch "${FILESDIR}"/${PN}-automake-1.13.patch
+ configure.in
+ default
+ mv configure.{in,ac} || die
eautoreconf
}
src_configure() {
- econf $(use_enable static-libs static) || die
+ econf $(use_enable static-libs static)
}
src_test() {
- for task in example/* ; do
- (
- cd "${task}"
- ./exec.sh || die "failed test in ${task}"
- )
+ local d
+ for d in example/*; do
+ cd "${d}"
+ ./exec.sh || die "failed test in ${d}"
+ cd - >/dev/null
done
}
src_install() {
- emake DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" install
+ einstalldocs
- if ! use static-libs ; then
- find "${ED}" -name "*.la" -type f -delete || die
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/example
+ insinto /usr/share/doc/${PF}
+ doins -r example
fi
- dodoc AUTHORS README || die
- dohtml -r doc/* || die
-
- if use examples ; then
- insinto /usr/share/doc/${PF}
- doins -r example || die
+ if ! use static-libs; then
+ find "${ED}" -name "*.la" -type f -delete || die
fi
}