summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/crm114
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/crm114')
-rw-r--r--app-text/crm114/Manifest1
-rw-r--r--app-text/crm114/crm114-20100106.ebuild82
-rw-r--r--app-text/crm114/metadata.xml25
3 files changed, 108 insertions, 0 deletions
diff --git a/app-text/crm114/Manifest b/app-text/crm114/Manifest
new file mode 100644
index 000000000000..97b3069c3f96
--- /dev/null
+++ b/app-text/crm114/Manifest
@@ -0,0 +1 @@
+DIST crm114-20100106-BlameMichelson.src.tar.gz 724672 SHA256 fb626472eca43ac2bc03526d49151c5f76b46b92327ab9ee9c9455210b938c2b SHA512 bb95fa50d6feef1a127e39e4005c4964b0096c3c7059f63bbf2293042351cf5ceeb7590fd1bedc64291ba556dfba96856dba8554f2f52a6cbaa3ad65012809c6 WHIRLPOOL 8ae6f01d5b7a3d8419662ea9a34a32d25c39f7aea7e35118eb20439f82cbad4d288478ebd87fb521c2871b654a137d4c432a7f7064f918e047b65a69e6be0518
diff --git a/app-text/crm114/crm114-20100106.ebuild b/app-text/crm114/crm114-20100106.ebuild
new file mode 100644
index 000000000000..f406281548f1
--- /dev/null
+++ b/app-text/crm114/crm114-20100106.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+MY_P="${P}-BlameMichelson.src"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A powerful text processing tool, mainly used for spam filtering"
+HOMEPAGE="http://crm114.sourceforge.net/"
+SRC_URI="http://crm114.sourceforge.net/tarballs/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE="mew mimencode nls normalizemime static test"
+
+RDEPEND="
+ static? ( dev-libs/tre[static-libs] )
+ !static? ( dev-libs/tre )
+ mew? ( app-emacs/mew )
+ mimencode? ( net-mail/metamail )
+ normalizemime? ( mail-filter/normalizemime )"
+DEPEND="${RDEPEND}
+ test? ( sys-apps/miscfiles )"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ sed \
+ -e "s#-O3 -Wall##" \
+ -e "s#^CC=.*#CC=$(tc-getCC)#" \
+ -i Makefile || die
+ # Upstream recommends static linking
+ if ! use static ; then
+ sed -i "s#LDFLAGS += -static -static-libgcc#LDFLAGS += ${LDFLAGS}#" Makefile || die
+ else
+ sed \
+ -e "s#LDFLAGS += -static -static-libgcc#LDFLAGS += ${LDFLAGS} -static -static-libgcc#" \
+ -i Makefile || die
+ fi
+
+ if use mimencode ; then
+ sed \
+ -e 's%#:mime_decoder: /mimencode -u/%:mime_decoder: /mimencode -u/%' \
+ -e 's%:mime_decoder: /mewdecode/%#:mime_decoder: /mewdecode/%' \
+ -i mailfilter.cf || die
+ elif use normalizemime ; then
+ sed \
+ -e 's%#:mime_decoder: /normalizemime/%:mime_decoder: /normalizemime/%' \
+ -e 's%:mime_decoder: /mewdecode/%#:mime_decoder: /mewdecode/%' \
+ -i mailfilter.cf || die
+ fi
+
+}
+
+src_install() {
+ dobin crm114 cssutil cssdiff cssmerge || die
+ dobin cssutil cssdiff cssmerge || die
+ dobin osbf-util || die
+
+ dodoc COLOPHON.txt CRM114_Mailfilter_HOWTO.txt FAQ.txt INTRO.txt || die
+ dodoc QUICKREF.txt CLASSIFY_DETAILS.txt inoc_passwd.txt || die
+ dodoc KNOWNBUGS.txt THINGS_TO_DO.txt README || die
+ docinto examples
+ dodoc *.example || die
+
+ insinto /usr/share/${PN}
+ doins *.crm || die
+ doins *.cf || die
+ doins *.mfp || die
+}
+
+src_test() {
+ emake megatest || die
+}
+
+pkg_postinst() {
+ elog "The spam-filter CRM files are installed in /usr/share/${PN}."
+}
diff --git a/app-text/crm114/metadata.xml b/app-text/crm114/metadata.xml
new file mode 100644
index 000000000000..67bc2045feef
--- /dev/null
+++ b/app-text/crm114/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>shell-tools</herd>
+<herd>proxy-maintainers</herd>
+<maintainer>
+ <email>steev@gentoo.org</email>
+ <name>Steev Klimaszewski</name>
+ <description>Maintainer</description>
+</maintainer>
+<maintainer>
+ <email>pacopablo@pacopablo.com</email>
+ <name>John Hampton</name>
+ <description>Consider him the user-maintainer of this package, and please
+ CC him on bug reports (if he's not the reporter).</description>
+</maintainer>
+<use>
+ <flag name='mew'>Add support for using the mewdecode mime decoder
+ (<pkg>app-emacs/mew</pkg>)</flag>
+ <flag name='mimencode'>Add support for using the mimencode mime
+ (<pkg>net-mail/metamail</pkg>)</flag>
+ <flag name='normalizemime'>Add support for using the normalizemime
+ (<pkg>mail-filter/normalizemime</pkg>)</flag>
+</use>
+</pkgmetadata>