summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/docbook-sgml-dtd/docbook-sgml-dtd-4.5.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/docbook-sgml-dtd/docbook-sgml-dtd-4.5.ebuild')
-rw-r--r--app-text/docbook-sgml-dtd/docbook-sgml-dtd-4.5.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-text/docbook-sgml-dtd/docbook-sgml-dtd-4.5.ebuild b/app-text/docbook-sgml-dtd/docbook-sgml-dtd-4.5.ebuild
new file mode 100644
index 000000000000..70869216c96a
--- /dev/null
+++ b/app-text/docbook-sgml-dtd/docbook-sgml-dtd-4.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils sgml-catalog
+
+MY_P="docbook-${PV}"
+DESCRIPTION="Docbook SGML DTD 4.5"
+HOMEPAGE="http://www.docbook.org/sgml/"
+SRC_URI="http://www.docbook.org/sgml/${PV}/${MY_P}.zip"
+
+LICENSE="docbook"
+SLOT="4.5"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE=""
+
+DEPEND=">=app-arch/unzip-5.41"
+RDEPEND="app-text/sgml-common"
+
+S=${WORKDIR}
+
+sgml-catalog_cat_include "/etc/sgml/sgml-docbook-${PV}.cat" \
+ "/usr/share/sgml/docbook/sgml-dtd-${PV}/catalog"
+sgml-catalog_cat_include "/etc/sgml/sgml-docbook-${PV}.cat" \
+ "/etc/sgml/sgml-docbook.cat"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${P}-catalog.diff
+}
+
+src_install() {
+ insinto /usr/share/sgml/docbook/sgml-dtd-${PV}
+ doins *.dcl *.dtd *.mod *.xml || die "doins failed"
+ newins docbook.cat catalog || die "newins failed"
+
+ dodoc README
+}