summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-06-16 12:43:39 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-06-16 12:44:33 +0200
commit85d889ec03fd4209a9bc8af3b8a1cf05a8d6b87b (patch)
treeaf09a9fca2b57c19e893aa2a7c86cc3c2cf30357 /app-text/docbook-xsl-ns-stylesheets
parentmedia-libs/glfw: drop old 3.3.1 (diff)
downloadgentoo-85d889ec03fd4209a9bc8af3b8a1cf05a8d6b87b.tar.gz
gentoo-85d889ec03fd4209a9bc8af3b8a1cf05a8d6b87b.tar.bz2
gentoo-85d889ec03fd4209a9bc8af3b8a1cf05a8d6b87b.zip
app-text/docbook-xsl-ns-stylesheets: Bump to version 1.79.1
Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-text/docbook-xsl-ns-stylesheets')
-rw-r--r--app-text/docbook-xsl-ns-stylesheets/Manifest1
-rw-r--r--app-text/docbook-xsl-ns-stylesheets/docbook-xsl-ns-stylesheets-1.79.1.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/app-text/docbook-xsl-ns-stylesheets/Manifest b/app-text/docbook-xsl-ns-stylesheets/Manifest
index 732ca89676c6..559252090869 100644
--- a/app-text/docbook-xsl-ns-stylesheets/Manifest
+++ b/app-text/docbook-xsl-ns-stylesheets/Manifest
@@ -1 +1,2 @@
DIST docbook-xsl-ns-1.78.0.tar.bz2 4992293 BLAKE2B 3bc93ca1dc45756121a4a3838093539957bba4ddffbbd7d27c5df6c63422a8694ea7d805cc9585ab1ce2d9092e35b91cd3bde97ee2fabb91c8c870eefa8ded1d SHA512 f3b9b52a4ba5670c17086cdf64674080ef82a9226f085887c23c53d2d102611d690895c71d14186cd84a25c7735b05d6c55207f4b2b9084d65889aaac7993cf3
+DIST docbook-xsl-ns-1.79.1.tar.bz2 21962317 BLAKE2B a68cc31ea8cb98fc07e198fe55f242c6438284d6fa75d4920a9ca7b5038732f966cc6653e058d7fafb26c0ff49f2039025a48a0f8c0392ee892951723703bce3 SHA512 23fd06870bd5afe4efcd08c8ad679821c202a62442b50657c093cbe9cd71b585a3c56a5534a0d41119f58bf98b1f9014a53ff2e48ab59075ec1827e7363980e9
diff --git a/app-text/docbook-xsl-ns-stylesheets/docbook-xsl-ns-stylesheets-1.79.1.ebuild b/app-text/docbook-xsl-ns-stylesheets/docbook-xsl-ns-stylesheets-1.79.1.ebuild
new file mode 100644
index 000000000000..3ad9535de821
--- /dev/null
+++ b/app-text/docbook-xsl-ns-stylesheets/docbook-xsl-ns-stylesheets-1.79.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DOCBOOKDIR="/usr/share/sgml/${PN/-//}"
+MY_PN="${PN%-stylesheets}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="XSL Stylesheets for Docbook"
+HOMEPAGE="https://github.com/docbook/wiki/wiki"
+SRC_URI="mirror://sourceforge/docbook/${MY_P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="ruby"
+
+RDEPEND=">=app-text/build-docbook-catalog-1.4
+ ruby? ( dev-lang/ruby )"
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+# Makefile is broken since 1.76.0
+RESTRICT=test
+
+# The makefile runs tests, not builds.
+src_compile() { :; }
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ # The changelog is now zipped, and copied as the RELEASE-NOTES, so we
+ # don't need to install it
+ dodoc AUTHORS BUGS NEWS README RELEASE-NOTES.txt TODO
+
+ insinto ${DOCBOOKDIR}
+ doins VERSION VERSION.xsl
+
+ local i
+ for i in $(find . -maxdepth 1 -mindepth 1 -type d -exec basename {} \;); do
+ [[ "${i}" == "epub" ]] && ! use ruby && continue
+
+ cd "${S}"/${i}
+ for doc in ChangeLog README; do
+ if [[ -e "${doc}" ]] ; then
+ mv ${doc} ${doc}.${i} || die
+ dodoc ${doc}.${i}
+ rm ${doc}.${i} || die
+ fi
+ done
+
+ doins -r "${S}"/${i}
+ done
+
+ if use ruby; then
+ local cmd="dbtoepub${MY_PN#docbook-xsl}"
+
+ # we can't use a symlink or it'll look for the library in the
+ # wrong path.
+ dodir /usr/bin
+ cat - > "${ED}"/usr/bin/${cmd} <<EOF
+#!/usr/bin/env ruby
+
+load "${DOCBOOKDIR}/epub/bin/dbtoepub"
+EOF
+ fperms 0755 /usr/bin/${cmd}
+ fi
+}
+
+pkg_postinst() {
+ build-docbook-catalog
+}
+
+pkg_postrm() {
+ build-docbook-catalog
+}